Closed Bug 1315760 Opened 3 years ago Closed 3 years ago

Use Ubuntu 16.04 docker image for Marionette tests

Categories

(Firefox Build System :: Task Configuration, task)

task
Not set

Tracking

(Not tracked)

RESOLVED FIXED
mozilla52

People

(Reporter: whimboo, Assigned: whimboo)

References

Details

(Whiteboard: [blocked by bug 1316040])

Attachments

(1 file)

We have a Ubuntu 16.04 docker image (bug 1281179) for a while now and a couple of test suites have been moved already. I feel that we should update our configs for Marionette tests in TC to make use of 16.04.

Andreas and David, do you have any objections? The current downside will only be that the download will be larger and the extraction of the docker image takes a longer time. But all that is no hard blocker for other suites, so it shouldn't be for us.
Flags: needinfo?(dburns)
Flags: needinfo?(ato)
Assignee: nobody → hskupin
This is fine if this is no more than a days worth of work. After that it would be good to spec it out. This is not something that has been accounted for.
Flags: needinfo?(dburns)
Flags: needinfo?(ato)
For the record, there’s nothing that prevents _Marionette_ from being run on the Ubuntu 16.04 image.  If other test jobs are already running on the Ubuntu 16.04 image, I guess Firefox has taken a decision that it does not significantly harm out test coverage to not test on older images.
If there are no regressions running our tests on Ubuntu 16.04 it should actually be a one line change by adding the following content to the marionette related TC task:

> docker-image: {"in-tree": "desktop1604-test"}

https://dxr.mozilla.org/mozilla-central/source/taskcluster/ci/desktop-test/tests.yml#159

(In reply to Andreas Tolfsen ‹:ato› from comment #2)
> Ubuntu 16.04 image, I guess Firefox has taken a decision that it does not
> significantly harm out test coverage to not test on older images.

Ubuntu 12.04 has been desupported a long time ago. It's actually not a release we should test anymore. The reason why the transition takes that long is that usually lots of tests have to be updated. Given that the transition for Firefox UI tests was smoothly, I don't expect (many) issues with Marionette either.

I will put together a patch later today and will run it dozen of times through try.
Status: NEW → ASSIGNED
(In reply to Henrik Skupin (:whimboo) from comment #3)
> Ubuntu 12.04 has been desupported a long time ago. It's actually not a
> release we should test anymore.

Right, but my point is more theoretical that if we only test on the latest and greatest Linux distributions, we might make accidental changes that break Firefox on older, but still supported versions with older libraries &c.
Depends on: 1316040
As the try builds show there is a permafail for a Marionette test under "Core / Selection", which I filed as bug 1316040. 

> Right, but my point is more theoretical that if we only test on the latest
> and greatest Linux distributions, we might make accidental changes that
> break Firefox on older, but still supported versions with older libraries &c.

I think that this is a totally different discussion which came up a couple of times in the past, and why we run our firefox-ui tests on different flavors - whereby not for Linux anymore. :/
Whiteboard: [blocked by bug 1316040]
Comment on attachment 8808593 [details]
Bug 1315760 - Use Ubuntu 16.04 docker image for Marionette tests.

https://reviewboard.mozilla.org/r/91398/#review92008

The only faced perma fail for Ubuntu 16.04 has been fixed. So I updated this patch for latest mozilla-central, and triggered another try. In case this will produce all green tests again, we should be fine to bump the docker image!
Attachment #8808593 - Flags: review?(dustin)
Comment on attachment 8808593 [details]
Bug 1315760 - Use Ubuntu 16.04 docker image for Marionette tests.

https://reviewboard.mozilla.org/r/91400/#review92026
Attachment #8808593 - Flags: review?(dustin) → review+
Pushed by hskupin@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c23a8d5e4088
Use Ubuntu 16.04 docker image for Marionette tests. r=dustin
https://hg.mozilla.org/mozilla-central/rev/c23a8d5e4088
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla52
Product: TaskCluster → Firefox Build System
You need to log in before you can comment on or make changes to this bug.