Support easy favicon lookup

RESOLVED DUPLICATE of bug 1315616

Status

RESOLVED DUPLICATE of bug 1315616
2 years ago
6 months ago

People

(Reporter: andy+bugzilla, Unassigned)

Tracking

Trunk

Firefox Tracking Flags

(firefox52 affected)

Details

(Whiteboard: [design-decision-approved])

(Reporter)

Description

2 years ago
Chrome supports a favicon lookup of the format:

chrome://favicon/<url>

I can't find much documentation on that, but its in quite a few add-ons as a match pattern in web_accessible_resources and permissions. It gives access to the favicon.

In Firefox we've got moz-anno:favicon: URLs

https://dxr.mozilla.org/mozilla-central/search?q=moz-anno&redirect=true

Which might be similar.

There's also bug 1315616 which suggests an API for getting the icon. 

If we go with moz-anno:favicon: URLs we'll end up with a different code path anyway from Chrome, unless we map chrome: to moz-anno:.

Finally: https://bugs.chromium.org/p/chromium/issues/detail?id=104102 mentions "Making chrome://favicon/ a host permission was a big mistake that has caused lots of heartache. ", but nothing seemed to change after that.
Blocks: 1311472
(Reporter)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Whiteboard: [design-decision-needed] → [design-decision-approved]
Duplicate of bug: 1315616

Updated

11 months ago
No longer blocks: 1311472

Updated

6 months ago
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.