Closed Bug 131654 Opened 18 years ago Closed 18 years ago

Selected default search engine is not persistent.

Categories

(SeaMonkey :: Search, defect)

x86
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 87998

People

(Reporter: philbrunner, Assigned: samir_bugzilla)

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9+) Gecko/20020314
BuildID:    20020314

Installing or activating a new Mozilla version causes the default search engine
to revert to Netscape. If user has selected google on 20020313, he/she is not
likely to want the selected default search engine to revert to Netscape when
he/she installs 20020314.


Reproducible: Always
Steps to Reproduce:
1.Select Google as default search engine with 20020314 and quit.
2.Install new Mozilla nightly or run (e.g.) 20020310 and quit.
3.Run 200314.

Actual Results:  Default search engine is now Netscape.

Expected Results:  Default search engine should be Google, the last engine user
selected.

Also, when google has been selected, Search/Search the Web should not use
Netscape as the search engine (it should use Google).
I think this is related to 128857.

I don't really mind Mozilla using Netscape as the default (although I greatly
prefer Google). But these "features" are not going to improve AOL or Netscape
popularity.
In step 2 of Steps to Reproduce the bug, it is also necessary to make some
configuration change before logging out. For example, select Google as the
default search engine.

If you make no configuration in step 2, then Google remains the selected search
engine in step 3.
This is because the ``engine://'' pseudo-protocol URI stored in the user profile
is absolute.  If the new installation is in a different location the user will
have to change once to restore her/his choice.  As rjc will tell us, engine://
URIs are absolute cause Sherlock plugins can live in the System folder on the
Mac.  (Of course, we could come up with a scheme that accounts for local plugins
and system plugins: engine://system/<relative_path> and
engine://local/<relative_path>.)
This bug does not occur with the Windows operating system 2002040203.
The bug is now worse than it was (Linux 2002040306). Now,I get Netscape as the
default search engine every time I launch Mozilla no matter what I chose the
last time!

The user_pref("network.search.url", "http://www.google.com"); is ignored in
user.js. It is also now ignored in all.js (it was not ignored in all.js in the
3/24 nightly).

Please fix this bug and quit telling me it's too hard. Obviously, it can be done
in Windows. The preferred fix would be to pay attention to the user_pref
statement in user.js so I could set it once and have it work for every new
installation.

Or is this a free labor for Netscape/AOL project and not a Mozilla project?
This is a dupe. Phil, if you want it fixed, then send a patch,
instead of moaning.
Whiteboard: DUPEME
John,
Please tell me the number of the bug that #131654 duplicates so I can clean up
the database.
Thanks,
Phil
Phil, spent a moment looking, I think bug 87998, but I can't be sure.

If you agree, you can mark it a dupe yourself :)

regards, john
This is a duplicate of bug# 87998 except that it is for the Linux O.S.
Will ask that 87998 be changed from "Windows" to "All".
Thanks to John Levon for finding the duplication.
Phil

*** This bug has been marked as a duplicate of 87998 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
Product: Core → SeaMonkey
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.