Closed Bug 13167 Opened 20 years ago Closed 20 years ago

apprunner/messenger crashes if profile manager was canceled...

Categories

(Core Graveyard :: Profile: BackEnd, defect, P1, critical)

Sun
Solaris
defect

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 8101

People

(Reporter: roland.mainz, Assigned: racham)

Details

Messenger startup crashes (core dump) if the profile manager was cancelled (e.g.
create profile window aborted with dtwm's close menu item).
(I tried to start messenger using apprunner's menu).

I got the following trace from GDB:
-- snip --
(gdb) bt
#0  0xfdb529a4 in nsMsgFolderCache::GetCacheElement (this=0xab7a00, uri=0xcc2a48
"mailbox://(null)@(null)",
    createIfMissing=0, result=0xffbec588) at
../../../../mailnews/base/src/nsMsgFolderCache.cpp:290
#1  0xfdacc8e4 in nsMsgDBFolder::ReadDBFolderInfo (this=0xcc5a58, force=0)
    at ../../../../mailnews/base/util/nsMsgDBFolder.cpp:195
#2  0xfc2e7f8c in nsMsgLocalMailFolder::UpdateSummaryTotals (this=0xcc5a58,
force=0)
    at ../../../../mailnews/local/src/nsLocalMailFolder.cpp:828
#3  0xfc2e6bb0 in nsMsgLocalMailFolder::GetSubFolders (this=0xcc5a58,
result=0xffbec930)
    at ../../../../mailnews/local/src/nsLocalMailFolder.cpp:372
#4  0xfdb439c0 in nsMsgFolderDataSource::createFolderChildNode (this=0xcb81b0,
folder=0xcc5a58, target=0xffbecbb8)
    at ../../../../mailnews/base/src/nsMsgFolderDataSource.cpp:886
#5  0xfdb43454 in nsMsgFolderDataSource::createFolderNode (this=0xcb81b0,
folder=0xcc5a58, property=0x394808,
    target=0xffbecbb8) at
../../../../mailnews/base/src/nsMsgFolderDataSource.cpp:737
#6  0xfdb41138 in nsMsgFolderDataSource::GetTarget (this=0xcb81b0,
source=0xcc5a58, property=0x394808, tv=1,
    target=0xffbecbb8) at
../../../../mailnews/base/src/nsMsgFolderDataSource.cpp:206
#7  0xfd9518d8 in CompositeDataSourceImpl::GetTarget (this=0xcb8188,
aSource=0xcc5a58, aProperty=0x394808,
    aTruthValue=1, aResult=0xffbecbb8) at
../../../../rdf/base/src/nsCompositeDataSource.cpp:734
#8  0xfd983400 in RDFGenericBuilderImpl::IsEmpty (this=0xcbee28,
aElement=0xcc70b0, aContainer=0xcc5a58)
    at ../../../../rdf/content/src/nsRDFGenericBuilder.cpp:2668
#9  0xfd97f3fc in RDFGenericBuilderImpl::BuildContentFromTemplate
(this=0xcbee28, aTemplateNode=0xcc5be0,
    aRealNode=0xcc5228, aIsUnique=0, aChild=0xcc5a58, aNaturalOrderPos=-1,
aNotify=1)
    at ../../../../rdf/content/src/nsRDFGenericBuilder.cpp:1996
#10 0xfd97f2b8 in RDFGenericBuilderImpl::BuildContentFromTemplate
(this=0xcbee28, aTemplateNode=0xcc5b80,
    aRealNode=0xcbe4b8, aIsUnique=1, aChild=0xcc5a58, aNaturalOrderPos=1,
aNotify=1)
    at ../../../../rdf/content/src/nsRDFGenericBuilder.cpp:1821
#11 0xfd980694 in RDFGenericBuilderImpl::CreateWidgetItem (this=0xcbee28,
aElement=0xcbe4b8, aProperty=0x394808,
    aChild=0xcc5a58, aNaturalOrderPos=1, aNotify=1) at
../../../../rdf/content/src/nsRDFGenericBuilder.cpp:2023
#12 0xfd981ab4 in RDFGenericBuilderImpl::CreateContainerContents (this=0xcbee28,
aElement=0xcbe4b8,
    aResource=0x80000000) at
../../../../rdf/content/src/nsRDFGenericBuilder.cpp:2318
#13 0xfd97925c in RDFGenericBuilderImpl::CreateContents (this=0xcbee28,
aElement=0xcbe4b8)
    at ../../../../rdf/content/src/nsRDFGenericBuilder.cpp:490
#14 0xfd999ea8 in XULDocumentImpl::CreateContents (this=0x990078,
aElement=0xcbe4b8)
    at ../../../../rdf/content/src/nsXULDocument.cpp:2582
#15 0xfd975e58 in RDFElementImpl::EnsureContentsGenerated (this=0x990078)
    at ../../../../rdf/content/src/nsRDFElement.cpp:2634
#16 0xfd97251c in RDFElementImpl::ChildCount (this=0xcbe4a8,
aResult=@0xffbed680)
    at ../../../../rdf/content/src/nsRDFElement.cpp:1531
#17 0xfd96f9dc in RDFElementImpl::GetChildNodes (this=0xcbe4a8,
aChildNodes=0xffbed840)
    at ../../../../rdf/content/src/nsRDFElement.cpp:657
#18 0xfd976d74 in RDFElementImpl::GetElementsByAttribute (aNode=0xcbe4a8,
aAttribute=@0xffbee190,
    aValue=@0xffbee148, aElements=0xba61f0) at
../../../../rdf/content/src/nsRDFElement.cpp:2830
#19 0xfd97705c in RDFElementImpl::GetElementsByAttribute (aNode=0x0,
aAttribute=@0xffbee190, aValue=@0xffbee148,
    aElements=0xba61f0) at ../../../../rdf/content/src/nsRDFElement.cpp:2871
#20 0xfd97705c in RDFElementImpl::GetElementsByAttribute (aNode=0x0,
aAttribute=@0xffbee190, aValue=@0xffbee148,
    aElements=0xba61f0) at ../../../../rdf/content/src/nsRDFElement.cpp:2871
#21 0xfd97705c in RDFElementImpl::GetElementsByAttribute (aNode=0x0,
aAttribute=@0xffbee190, aValue=@0xffbee148,
    aElements=0xba61f0) at ../../../../rdf/content/src/nsRDFElement.cpp:2871
#22 0xfd97705c in RDFElementImpl::GetElementsByAttribute (aNode=0x0,
aAttribute=@0xffbee190, aValue=@0xffbee148,
    aElements=0xba61f0) at ../../../../rdf/content/src/nsRDFElement.cpp:2871
#23 0xfd97705c in RDFElementImpl::GetElementsByAttribute (aNode=0x0,
aAttribute=@0xffbee190, aValue=@0xffbee148,
    aElements=0xba61f0) at ../../../../rdf/content/src/nsRDFElement.cpp:2871
#24 0xfd970d4c in RDFElementImpl::GetElementsByAttribute (this=0xb198d8,
aAttribute=@0xffbee190, aValue=@0xffbee148,
    aReturn=0xffbee188) at ../../../../rdf/content/src/nsRDFElement.cpp:1076
#25 0xfe582c94 in nsWebShellWindow::ShowAppropriateChrome (this=0x892308)
    at ../../../../xpfe/appshell/src/nsWebShellWindow.cpp:2226
---Type <return> to continue, or q <return> to quit---
#26 0xfe581964 in nsWebShellWindow::OnEndDocumentLoad (this=0x892308,
loader=0x7ce0e8, channel=0x7cedf8, aStatus=0,
    aDocObserver=0x7cd88c) at
../../../../xpfe/appshell/src/nsWebShellWindow.cpp:1911
#27 0xff258f10 in nsWebShell::OnEndDocumentLoad (this=0x7cd878, loader=0x7ce0e8,
channel=0x7cedf8, aStatus=0,
    aWebShell=0x7cd88c) at ../../../webshell/src/nsWebShell.cpp:3302
#28 0xff24fb84 in nsDocLoaderImpl::FireOnEndDocumentLoad (this=0x7ce0e8,
aLoadInitiator=0x7ce0e8, aStatus=0)
    at ../../../webshell/src/nsDocLoader.cpp:1227
#29 0xff24f840 in nsDocLoaderImpl::OnStopRequest (this=0x7ce0e8,
channel=0xbe2e90, ctxt=0x0, status=0, errorMsg=0x0)
    at ../../../webshell/src/nsDocLoader.cpp:1097
#30 0xfd7a25f0 in nsLoadGroup::RemoveChannel (this=0x7ce128, channel=0xbe2e90,
ctxt=0x0, status=0, errorMsg=0x0)
    at ../../../../netwerk/base/src/nsLoadGroup.cpp:548
#31 0xfd758528 in nsFileChannel::OnStopRequest (this=0xbe2e90, channel=0xbe2e90,
context=0x0, aStatus=0, aMsg=0x0)
    at ../../../../../netwerk/protocol/file/src/nsFileChannel.cpp:795
#32 0xfd79574c in nsOnStopRequestEvent::HandleEvent (this=0xbe2d00)
    at ../../../../netwerk/base/src/nsAsyncStreamListener.cpp:273
#33 0xfd795148 in nsStreamListenerEvent::HandlePLEvent (aEvent=0xbe2d00)
    at ../../../../netwerk/base/src/nsAsyncStreamListener.cpp:149
#34 0xfee63088 in PL_HandleEvent (self=0xbe2d00) at plevent.c:509
#35 0xfee62f08 in PL_ProcessPendingEvents (self=0x9b1d8) at plevent.c:470
#36 0xfef033f0 in nsEventQueueImpl::ProcessPendingEvents (this=0xa1480)
    at ../../../xpcom/threads/nsEventQueue.cpp:118
#37 0xff340e68 in event_processor_callback (data=0xa1480, source=6,
condition=GDK_INPUT_READ)
    at ../../../../widget/src/gtk/nsAppShell.cpp:149
#38 0xfebcbf24 in gdk_io_invoke (source=0xedf08, condition=G_IO_IN,
data=0xcefd0) at gdkevents.c:878
#39 0xfeb55478 in g_io_unix_dispatch (source_data=0x9e6e0,
current_time=0xffbeec48, user_data=0xcefd0)
    at giounix.c:135
#40 0xfeb57138 in g_main_dispatch (current_time=0xffbeec48) at gmain.c:652
#41 0xfeb57a24 in g_main_iterate (block=1228, dispatch=1) at gmain.c:870
#42 0xfeb57c34 in g_main_run (loop=0x1dd6f8) at gmain.c:928
#43 0xfecc5fbc in gtk_main () at gtkmain.c:475
#44 0xff3415e0 in nsAppShell::Run (this=0xa5d98) at
../../../../widget/src/gtk/nsAppShell.cpp:371
#45 0xfe57a064 in nsAppShellService::Run (this=0x83d28) at
../../../../xpfe/appshell/src/nsAppShellService.cpp:470
#46 0x141b4 in main1 (argc=0, argv=0xffbef0dc) at
../../../xpfe/bootstrap/nsAppRunner.cpp:761
#47 0x14384 in main (argc=1, argv=0xffbef0dc) at
../../../xpfe/bootstrap/nsAppRunner.cpp:828
-- snip --

Test environment: Solaris 7 SPARC, M9 build with gcc 2.95.1
Assignee: ssu → dbragg
Component: Install Wizard → Profile Migration
Assignee: dbragg → racham
We need to create a Profile Manager Component so these bugs go to the right
place the first time.  This is a new profile so the Profile Migration code is
never called.  So this can't be a migration bug.  Re-assigning to Bhuvan.
Component: Profile Migration → Profile Manager
change component to profile manager...
Status: NEW → ASSIGNED
Target Milestone: M11
Grace, please let me know if you can reproduce this with latest builds.
I am unable to reproduce on Linux box using spe15 build.  I am able to cancel
out of Create Profile Wizard as well as the Mail Account Setup Wizard. I was
able to send mail despite no profile or prefs.
But I didn#t click on any CANCEL button. I kicked the window away with the
window manager's "Close Window" menu item.
AKAIK this is different from a "cancel"-Button in the Profile Manager...
Roland,
Are you still experiencing this problem..? What build do you have..? Let us know
us know these details so that we can work on reproducing this bug and direct
it to the right owner.

Adding bienvenu@netscape.com (from mailnews) to th ecc list as the stack trace
suggests the crash occurred while starting the messenger.
Please send steps you took to see this crash.
1. what command to launch (apprunner -mail, apprunner -installer etc)
2. what screen comes up next? - profile manager or create profile wizard?
3. after 'canceling' by pressing [x] in upper right corner- I now go into
Account Setup Wizard since I launched with apprunner -mail

The confusion is the different ways to launch, (-installer calls the
ProfileManager with Migration, -ProfileManager brings up CreateWizard if
registry has been deleted, -mail calls messenger but is looking for profile as
in step 2.....)
also - please what build are you using?

thanks,
Grace
This crash occurs because no profile directory is set - we shouldn't be able to
get past the profile wizard without a profile directory getting set.
> Are you still experiencing this problem..?
Mhhh, yes, still usung the M9 build...

> What build do you have..?

As I wrote in the initial bug report: I build it on Solaris 7 sparc from the M9
sources...

> Let us know us know these details so that we can work on reproducing this bug
and direct it to the right owner.

details... as I wrote: I used the window-managers option to close the window,
NOT the Close/Finish button of the profile manager... thats all...
How I launched mozilla:
1. rm -R ~/.mozilla
2. ./mozilla-apprunner
Product: MailNews → Browser
Moving to browser component
Priority: P3 → P1
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
The root cause of this bug is that we didn't catch the window close from the
window manager's exit button.  This is a dup of 8101.

*** This bug has been marked as a duplicate of 8101 ***
Status: RESOLVED → VERIFIED
Component: Profile Manager → Profile Manager BackEnd
Moving all Profile Manager bugs to new Profile Manager Backend component.
Profile Manager component to be deleted.
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.