[PP]Profile Manager [exit] button takes to apprunner

VERIFIED FIXED in M12

Status

Core Graveyard
Profile: BackEnd
P3
normal
VERIFIED FIXED
19 years ago
2 years ago

People

(Reporter: Grace Bush, Assigned: racham)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Profile Manager shows two buttons, [exit] and [start communicator]. They both do
the same thing.  When I pressed [exit] I expected to return to console ie exit
the Profile Manager

(build 1999061308)
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M8
(Assignee)

Comment 1

19 years ago
We need to identify a way exit the whole app in a sane state on clicking the
'Exit' button. Moving the TFV to M8.

Comment 2

19 years ago
This isn't critical and it isn't done - moving to M9.
Target Milestone: M8 → M9
(Assignee)

Updated

19 years ago
Target Milestone: M9 → M10
(Assignee)

Comment 3

19 years ago
Moving TFV to M10. Including Ramiro onthe cc list for general consultation.

Ramiro, Is there an API that you are aware of which when called quits the whole
app not just the (toplevel)window in which it happened..?

Comment 4

19 years ago
P3s aren't going to make it in M10.  Bulk moving to M11.

Updated

18 years ago
Blocks: 12696

Comment 5

18 years ago
These bugs are not critical for beta 1, moving out.
adding myself to the cc list.

Updated

18 years ago
No longer blocks: 12696

Updated

18 years ago
Target Milestone: M15 → M12

Comment 7

18 years ago
Failing to exit the app is causing mail to crash.  Need this in the beta.

Comment 8

18 years ago
*** Bug 13167 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 9

18 years ago
Exit now exists the whole application. On hitting Exit, the javascript calls the
interface that makes the file profile services to forget about the current
profile. The in the profile code, we check to see if there is a current profile,
if there is no current profile, we quit the whole application. Part of Seth's
fixes. Marking fixed.
(Reporter)

Updated

18 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 10

18 years ago
this has been working for a while now, verified in build 1999101208

Updated

18 years ago
Component: Profile Manager → Profile Manager BackEnd

Comment 11

18 years ago
Moving all Profile Manager bugs to new Profile Manager Backend component.
Profile Manager component to be deleted.
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.