Closed Bug 131675 Opened 23 years ago Closed 23 years ago

percentage widths on images within inlines based on remaining space

Categories

(Core :: Layout, defect)

defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 110358

People

(Reporter: chris.hellwig, Assigned: attinasi)

References

()

Details

Attachments

(1 file)

It seems that a construct like
 
<center> <a href="AKTUELLF.HTM" target="_self"><img border="0"
src="images/aktuelfj.jpg" width="32%">
</a> <a href="AKTUELLT.HTM" target="_self"><img border="0"
src="images/aktueltn.jpg" width="32%">
</a> <a href="AKTUELLM.HTM" target="_self"><img border="0"
src="images/aktuelmn.jpg" width="32%">
</a> </center>
 
leads to a situation where the first image shows up correctly (32% of page
width) while the second image fits to 32% of the remaining page and the so on.

The page is viewable with Netscape 4.x, IE5.x and even with IBMs outdated
WebExplorer.
Confirmed (I can't change the status, though). Will attach HTML showing exactly
what does and doesn't work.
Attached file Testcase
HTML page showing what does and doesn't work.
Hm, interesting, confirming on linux 2002031721.
Status: UNCONFIRMED → NEW
Ever confirmed: true
http://www.w3.org/TR/html401/struct/objects.html#adef-width-IMG : "...lengths
expressed as percentages are based on the horizontal or vertical space currently
available..." ...So what does "currently" mean? :) ->style
Assignee: asa → dbaron
Component: Browser-General → Style System
QA Contact: doronr → ian
The problem here is that the behaviour differs between
<IMG src="..." width="32%"><IMG src="..." width="32%">
and
<A href="..."><IMG src="..." width="32%"></A><A href="..."><IMG src="..."
width="32%"></A>

In the first case the images are all the same size - this behaviour is 'right',
and should be the interpretation of the amiguity in the HTML4 spec. The addition
of <A href> (second case) shouldn't make any difference!
Did this break recently?  The "work" / "don't work" distinction in attachment
74713 [details] is correct -- see the following parts of CSS2:
http://www.w3.org/TR/REC-CSS2/visudet.html#the-width-property
http://www.w3.org/TR/REC-CSS2/visudet.html#containing-block-details (point 2)

Is this specific to images or can it be reproduced with other replaced inline
elements (text inputs?, buttons? -- if they respond to 'width' at all)?
Component: Style System → Layout
Summary: Image width don't fit → percentage widths on images within inlines based on remaining space
This definitely didn't break recently.  I see the bug in a build from September,
in Mozilla 0.9, and in M18.
Anyway, ->Layout.
Assignee: dbaron → attinasi
QA Contact: ian → petersen

*** This bug has been marked as a duplicate of 110358 ***
Status: NEW → RESOLVED
Closed: 23 years ago
Resolution: --- → DUPLICATE
Changing QA contact
QA Contact: petersen → moied
verified dup
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: