percentage widths on images within inlines based on remaining space

RESOLVED DUPLICATE of bug 97695

Status

()

Core
Layout
--
major
RESOLVED DUPLICATE of bug 97695
17 years ago
15 years ago

People

(Reporter: Sean Harding, Assigned: Marc Attinasi)

Tracking

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
On http://www.dogcow.org/yuck.html I have four images. Two side-by side on two
lines. All have width set to "33%". The top two images are not links, the bottom
two are. The top two images are both shown as the same size, the bottom two are
not. The second image on the bottom line seems to be scaled to make it take 33%
of the space remaining AFTER the first images is placed. The only difference
here is that the second two images are links (wrapped with <a href=...> ...
</a>), yet they render completely differently.

Linux build 2001111506 on FreeBSD.
No dupes found. Marking NEW.

Does this belong in DOM HTML?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: xhtml
(Reporter)

Comment 2

17 years ago
FWIW, this isn't xhtml-specific. That's just what I happened to write my example in.
Sean: Aha. In that case, removing "xhtml" keyword (nonetheless, kudos to you for
writing in xhtml in the first place). 
Keywords: xhtml
Not a DOM problem, over to layout.
Assignee: jst → attinasi
Component: DOM HTML → Layout
QA Contact: stummala → petersen

Updated

16 years ago
Target Milestone: --- → Future
*** Bug 128870 has been marked as a duplicate of this bug. ***

Comment 6

16 years ago
128870 might well be the same problem, but my analysis was slightly different.

For example; does it matter if you take away the first image on each line?
I originally had two images, and found it made no difference with only the
second - it was the amount of text (possibly just 'space') before the 'second'
image which seemed to affect its size.

http://bugzilla.mozilla.org/show_bug.cgi?id=128870 has another testcase showing
this behaviour.
*** Bug 131675 has been marked as a duplicate of this bug. ***
Old Summary: "Image width is interpreted differently if image is a link"

New summary: "percentage widths on images within inlines based on remaining
space"
Summary: Image width is interpreted differently if image is a link → percentage widths on images within inlines based on remaining space
(Reporter)

Comment 9

16 years ago
Are you sure that new summary is completely accurate? As my example shows, the
problem only exists when the images are with an <a>...

Comment 10

16 years ago
Created attachment 74740 [details]
Testcases

Was just about to add this to bug 131675, but Boris duped it :-)

I discovered a few other things:
* <OBJECT> is similarly affected - with or without <A href=...> round it.
* Bug still present when using style="width: 32%" rather than width="32%".
* <PRE> round the <IMG>s or <OBJECT>s causes it to work properly.
* One <A href...> round 3 <IMG>s is OK.
* Problem is still present if the offending items are within a table cell,
<DIV>
  or <CENTER>

Comment 11

16 years ago
Also seeing this on Win2k. Platform/OS --> All
OS: Linux → All
Hardware: PC → All

Comment 12

16 years ago
No other browser does this, and a LOT of sites do this.  You guys REALLY should
fix this before 1.0 - it shouldn't be hard at all

Comment 13

16 years ago
Comment 12: That would be kinda impossible as 1.0 has already been released.
Severity: normal → major

Comment 14

16 years ago
is work on this proceeding??

I was hoping to roll out a site using % and was just wondering...

http://www.peepo.com/w3/svg-jpg/svg-jpg.html
looks damn silly your way.

thanks

Comment 15

15 years ago
See also bug 97695.
*** Bug 80617 has been marked as a duplicate of this bug. ***
*** This bug has been marked as a duplicate of 97695 ***

*** This bug has been marked as a duplicate of 97695 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Updated

15 years ago
No longer blocks: 194804
You need to log in before you can comment on or make changes to this bug.