Figure out how to send APZ hit-testing information over to the compositor with WR

RESOLVED DUPLICATE of bug 1357754

Status

()

Core
Graphics: WebRender
P3
normal
RESOLVED DUPLICATE of bug 1357754
2 years ago
a year ago

People

(Reporter: kats, Unassigned)

Tracking

52 Branch
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox52 affected)

Details

(Whiteboard: [gfx-noted])

Now that we have e10s stood up in the WR world, we need to find a way to send hit-testing information from the content side to the compositor side for APZ to use. In the non-WR world this is sent as part of the layer tree, with event regions attached to each layer. In the WR world we don't send over layers at all, so we need to extract the event regions information beforehand and then ship that over PWebRenderBridge somehow. This probably depends on doing bug 1316903 first.
Blocks: 1339474
I'm going to forward-dupe this to bug 1357754 which has patches to do this. We might want to change how hit-testing is done further down the road, but we can file something else for that.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1357754
You need to log in before you can comment on or make changes to this bug.