Closed Bug 1339474 (wr-apz) Opened 4 years ago Closed 3 years ago

[meta] APZ in QuantumRender

Categories

(Core :: Graphics: WebRender, defect, P3)

Other Branch
defect

Tracking

()

RESOLVED FIXED
mozilla56
Tracking Status
firefox56 --- fixed

People

(Reporter: kats, Assigned: kats)

References

(Depends on 4 open bugs)

Details

(Keywords: meta, Whiteboard: [gfx-noted])

Attachments

(1 file)

This is a metabug to track the work needed to get APZ up and running in QuantumRender builds.
Alias: wr-apz
Depends on: 1355602
Depends on: 1355791
Depends on: 1357065
I have a patch queue that in theory pushes scroll metadata and hit testing information over to APZ. I'll split it into a separate bug but linking it here for now: https://github.com/staktrace/gecko-dev/commits/wr-apz
Depends on: 1357754
Depends on: 1361497
We'll need a WR update including csets 2a21b1a and 48a098f for APZ.
Depends on: 1363683
Depends on: 1364525
Depends on: 1364987
Depends on: 1366295
Depends on: 1367837
Depends on: 1367911
Depends on: 1368487
Depends on: 1368496
Depends on: 1368551
Depends on: 1369840
Depends on: 1372321
Depends on: 1372603
Depends on: 1372912
Depends on: 1373349
Depends on: 1373378
Depends on: 1373802
Depends on: 1361720
Depends on: 1374326
I'd like to turn this on sooner rather than later, even though I haven't fixed all the reftests yet. I've opened bugs for the remaining reftest failures and there's not that many. I'll continue working on them. Given that there's some large-ish changes coming down the pipe (not just upstream WR, but also ethan's no-layers changes) I'd like to make sure we have APZ coverage in automation and can catch regressions easily. I also think it would be worthwhile getting people using APZ in WR so we can catch problems faster.
Assignee: nobody → bugmail
So the try push is green enough. But running the build locally doesn't produce great results. Loading simple pages is fine but CNN takes a long time and seems to eat my CPU. I'll need to investigate.
Turned out the issues in comment 5 were because I was running a debug build. Opt builds seem to behave much more normally.
Comment on attachment 8879287 [details]
Bug 1339474 - Enable APZ in QuantumRender builds.

https://reviewboard.mozilla.org/r/150566/#review155296
Attachment #8879287 - Flags: review?(jmuizelaar) → review+
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0aa71b712379
Enable APZ in QuantumRender builds. r=jrmuizel
https://hg.mozilla.org/mozilla-central/rev/0aa71b712379
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla56
Depends on: 1242362
Depends on: 1375843
Depends on: 1376044
Depends on: 1376449
Depends on: 1587369
Depends on: 1604280
Depends on: 1653796
You need to log in before you can comment on or make changes to this bug.