Intermittent test_timeouts.py TestTimeouts.test_search_timeout_found_settimeout | NoSuchElementException: Unable to locate element: newDiv

REOPENED
Unassigned

Status

P5
normal
REOPENED
2 years ago
8 months ago

People

(Reporter: intermittent-bug-filer, Unassigned)

Tracking

({intermittent-failure, leave-open, test-disabled})

Trunk
intermittent-failure, leave-open, test-disabled
Points:
---

Firefox Tracking Flags

(firefox51 unaffected, firefox52 wontfix, firefox-esr52 unaffected, firefox53 disabled, firefox54 disabled, firefox55 disabled)

Details

(Whiteboard: [stockwell disabled])

Attachments

(1 attachment)

Affected code here:

> button = self.marionette.find_element(By.ID, "createDivButton")
> button.click()
> self.marionette.set_search_timeout(8000)
> self.assertEqual(HTMLElement, type(self.marionette.find_element(By.ID, "newDiv")))

So a click on the createDivButton in test.html will delay the creation of the newDiv div by 2000ms. Maybe calling set_search_timeout was not successful here.
From gecko.log:

> 1479009963991	Marionette	TRACE	conn755 -> [0,8,"timeouts",{"implicit":8000}]
> 1479009963994	Marionette	TRACE	conn755 <- [1,8,null,{}]
> 1479009964007	Marionette	TRACE	conn755 -> [0,9,"findElement",{"using":"id","value":"newDiv"}]
[..]
> 1479009989855	Marionette	TRACE	conn755 <- [1,9,{"error":"no such element","message":"Unable to locate element: newDiv","stacktrace":""},null]

The timeout used here is 25852ms. What's going on here?
Flags: needinfo?(ato)
I don’t know.  I don’t have the bandwidth to look at this right now, but this is a likely contender for something to look at next.
Flags: needinfo?(ato)
8 failures in 715 pushes (0.011 failures/push) were associated with this bug in the last 7 days.  

Repository breakdown:
* mozilla-inbound: 3
* mozilla-central: 2
* mozilla-aurora: 2
* autoland: 1

Platform breakdown:
* linux32: 8

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1317121&startday=2016-11-14&endday=2016-11-20&tree=all
status-firefox51: --- → unaffected
status-firefox52: --- → affected
status-firefox53: --- → affected
Duplicate of this bug: 1323293
5 failures in 836 pushes (0.006 failures/push) were associated with this bug in the last 7 days.  
Repository breakdown:
* mozilla-inbound: 3
* autoland: 2

Platform breakdown:
* android-4-3-armv7-api15: 5

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1317121&startday=2017-02-06&endday=2017-02-12&tree=all
8 failures in 790 pushes (0.01 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* try: 3
* mozilla-central: 2
* autoland: 2
* graphics: 1

Platform breakdown:
* android-4-3-armv7-api15: 8

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1317121&startday=2017-03-06&endday=2017-03-12&tree=all
20 failures in 777 pushes (0.026 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* autoland: 11
* try: 2
* graphics: 2
* oak: 1
* mozilla-release: 1
* mozilla-inbound: 1
* mozilla-central: 1
* mozilla-beta: 1

Platform breakdown:
* android-4-3-armv7-api15: 20

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1317121&startday=2017-03-13&endday=2017-03-19&tree=all
10 failures in 845 pushes (0.012 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* autoland: 3
* mozilla-inbound: 2
* mozilla-central: 2
* mozilla-beta: 2
* mozilla-aurora: 1

Platform breakdown:
* android-4-3-armv7-api15: 10

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1317121&startday=2017-03-27&endday=2017-04-02&tree=all
Mass wontfix for bugs affecting firefox 52.
status-firefox52: affected → wontfix

Updated

2 years ago
See Also: → bug 1306848

Updated

2 years ago
Assignee: nobody → gbrown
Created attachment 8855369 [details] [diff] [review]
skip test on Android

This looks just like bug 1306848 - let's handle it the same way.
Attachment #8855369 - Flags: review?(ato)
Attachment #8855369 - Flags: review?(ato) → review+

Comment 12

2 years ago
Pushed by gbrown@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/73125874d9b9
Skip TestTimeouts.test_search_timeout_found_settimeout on Android; r=ato

Updated

2 years ago
Assignee: gbrown → nobody
Keywords: leave-open
Whiteboard: [stockwell disabled]

Comment 13

2 years ago
uplift
https://hg.mozilla.org/releases/mozilla-aurora/rev/90043851b77d
https://hg.mozilla.org/releases/mozilla-beta/rev/073ec1b8460a
status-firefox53: affected → disabled
status-firefox54: --- → disabled
status-firefox55: --- → disabled
status-firefox-esr52: --- → unaffected
7 failures in 867 pushes (0.008 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* mozilla-beta: 2
* mozilla-aurora: 2
* oak: 1
* mozilla-inbound: 1
* autoland: 1

Platform breakdown:
* android-4-3-armv7-api15: 7

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1317121&startday=2017-04-03&endday=2017-04-09&tree=all
1 failures in 824 pushes (0.001 failures/push) were associated with this bug in the last 7 days.    

Repository breakdown:
* mozilla-release: 1

Platform breakdown:
* windows7-32-nightly: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1317121&startday=2017-10-02&endday=2017-10-08&tree=all
Only preent on release in the last four months.
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → FIXED
Sorry, this was just disabled on Android.
Status: RESOLVED → REOPENED
Keywords: test-disabled
OS: Unspecified → All
Priority: -- → P5
Hardware: Unspecified → All
Resolution: FIXED → ---
Version: Version 3 → Trunk
You need to log in before you can comment on or make changes to this bug.