Top of Help window is under the menu bar (doesn't resize if larger than screen)

RESOLVED WORKSFORME

Status

()

Core
XUL
RESOLVED WORKSFORME
16 years ago
9 years ago

People

(Reporter: Joel Nelson (don't send email), Unassigned)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

16 years ago
I can't close Mozilla Help without closing Mozilla since when the Help 
window opens the toolbar (Print button) and any buttons to close the 
window are hidden under the Mac OS X menu bar.    I am using 800x600 
screen resolution.

Comment 1

16 years ago
WorksForMe using FizzillaCFM/2002041712 (RC1). The Help window opens entirely
within the screen boundaries.

Joel, can you still reproduce this problem using a current build?

Comment 2

16 years ago
I'm seeing this bug too, on maybe half my attempts to open Mozilla Help in
800x600. Still happening with yesterday's builds, both trunk and 1.0.0 branch.
(Screenshot coming.)

I'd guess it also happens on other platforms, but doesn't get noticed because
only on OS X do you *need* the title bar to grab, move or resize the window.

A workaround is to change to 1024x768 and back. But apart from that, as Joel
says, there is no other way out than to quit Mozilla. When Help is the only open
window, you can't even open another from the menus.

I'd suggest upping the severity, as I imagine 1.0 will attract quite a few
newcomers who will *need* a functional help system.

Comment 3

16 years ago
Created attachment 82894 [details]
screenshot

Comment 4

16 years ago
Created attachment 82912 [details]
screenshot

One way to pretty reliably reproduce this bug (100% success this morning) is
to:

1. Set resolution to 800x600;
launch Mozilla; choose Help > Help Contents;
2. Change resolution to 1024x768;
   Resize the Help window to be very tall and thin;
   Quit Mozilla;
3. Repeat step 1;
   (Help now opens with its title bar off screen.)

A contrived procedure admittedly, but the point is that

Comment 5

16 years ago
Created attachment 82914 [details]
screenshot

One way to pretty reliably reproduce this bug (100% success this morning) is
to:

1. Set resolution to 800x600;
   Launch Mozilla;
   Choose Help > Help Contents;
2. Change resolution to 1024x768;
   Resize the Help window to be very tall and thin;
   Quit Mozilla;
3. Repeat step 1: Help now opens out of range.

(A contrived procedure admittedly, but the point is that no window should ever
open with its title bar off screen.)

Comment 6

16 years ago
(Sorry for the repeat comment - there is, obviously, a keyboard shortcut for
"submit" that I wasn't aware of.)

Comment 7

16 years ago
Confirmed, though I didn't have to relaunch Mozilla. Simply decreasing
resolution to 800 by 600, launching Mozilla, then spawning Help was enough to
create a window too large for the scren.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 8

16 years ago
toolkit
Assignee: oeschger → jaggernaut
Component: Help → XP Toolkit/Widgets
QA Contact: tpreston → jrgm

Updated

16 years ago
Blocks: 161561

Updated

15 years ago
Summary: Top of Help window is under the menu bar → Top of Help window is under the menu bar (doesn't resize if larger than screen)

Updated

10 years ago
Assignee: jag → nobody

Comment 9

9 years ago
still see this?

Comment 10

9 years ago
I've tried this with a seamonkey trunk build a couple of times now. First, I doubt that this was/is restricted to the help window.

But I think we can close this as wfm. While it's certainly possible to open a window larger than the screen if you play with the screen resolution, it looks like the titlebar newer spawns outside/under the menubar. That is, it seems impossible to make a window resize "upwards" under the menubar.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.