Closed Bug 1318702 Opened 5 years ago Closed 3 years ago

Firefox window goes black when screen sharing a Google Chrome tab

Categories

(Core :: WebRTC: Audio/Video, defect, P3)

50 Branch
x86
Windows 10
defect

Tracking

()

RESOLVED DUPLICATE of bug 1398716

People

(Reporter: luismec90, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

2.48 MB, application/x-shockwave-flash
Details
Attached file ff_b.swf
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/54.0.2840.99 Safari/537.36

Steps to reproduce:

On Google Hangouts using Firefox I tried to screen sharing a Google Chrome tab.

PS: I was using Firefox 50.0 and windows 10.


Actual results:

I got a black screen


Expected results:

I should see the google chrome window without any problem
OS: Unspecified → Windows 10
Priority: -- → P2
Hardware: Unspecified → x86_64
I'm not a user of GG Hangouts, so what's the link to Hangouts's screensharing feature?
Flags: needinfo?(luismec90)
Hello Loic, thank your for your reply

Just go to https://hangouts.google.com/ and start a hangout, then on the left side, click on the screen icon and select the window you want to share.
Priority: P2 → --
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:53.0) Gecko/20100101 Firefox/53.0

I have tested this issue on Windows 10 x64 with the latest Firefox(50.0) and the latest Nightly (53.0a1-20161122030216) with e10s enabled/disabled and could not reproduce it.
After going to https://hangouts.google.com/ and starting a video hangout, a new window is opened and promtps to install "GoogleVoiceAndVideoSetup.exe", after installing it and re-starting the call, it still prompts to install the Google plugin.
I have also tried restarting the browser and the Machine, still unable to initiate the video hangout.
The following error was displayed in the Browser console:

The character encoding of a framed document was not declared. The document may appear different if viewed without the document framing it.  hscv
The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol.  openinstallpage.html
Key event not available on some keyboard layouts: key=“r” modifiers=“accel,alt” id=“toggleReaderMode”  browser.xul
Key event not available on some keyboard layouts: key=“i” modifiers=“accel,alt,shift” id=“key_browserToolbox”  browser.xul
Attempt to set a forbidden header was denied: Connection  3578082692-lcs_client_bin.js:93:385
Component: Untriaged → Plug-ins
Product: Firefox → Core
Emil, this won't work on the FF64 builds because those don't support the Google video plugin. Only FF32 supports the plugin and is worth testing.
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0

I have re-tested this issue on Windows 10 x64 and x32 with Firefox release x32 build (50.0.1) and managed to reproduce it.
After going to https://hangouts.google.com/ and starting a video hangout, when using the screen sharing feature to share a Google Chrome tab, the Firefox window goes black.

When testing with Nighty x32(53.0a1-20161128030212) and Firefox Developer Edition(52.0a2-20161128004004), I'm encountering the same issue as described in comment 3.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Hardware: x86_64 → x86
Did it use to work with FF49 or 48?
Summary: Screen sharing goes black → Firefox window goes black when screen sharing a Google Chrome tab on Google Hangouts
Flags: needinfo?(luismec90)
Duplicate of this bug: 1469863
Rank: 25
Component: Plug-ins → WebRTC: Audio/Video
Priority: -- → P3
Summary: Firefox window goes black when screen sharing a Google Chrome tab on Google Hangouts → Firefox window goes black when screen sharing a Google Chrome tab
Duplicate of this bug: 1490646
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1398716
You need to log in before you can comment on or make changes to this bug.