Closed Bug 1318939 Opened 7 years ago Closed 1 year ago

Slow switching between tabs

Categories

(Firefox :: Tabbed Browser, defect)

50 Branch
defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: foxb, Unassigned)

References

(Blocks 2 open bugs)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20161104212021

Steps to reproduce:

Open multiple tabs.
Wait for them to load (Spinning circle to dissapear)
Switch to another tab


Actual results:

I get another spinning circle into main windows for about 2-10s.



Expected results:

To see web page almost immediately.
Is it reproducible?

1) in safe mode:
https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

2) with a fresh profile:
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles

If it's reproducible with a fresh profile, can you enter about:support in the location bar and check if Multiprocess Windows is enabled.
Safe mode -> reproducible
Fresh profile -> reproducible

Multiprocess
Multiprocess Windows 	1/1 (Enabled by default)

Hardware information
CPU: AMD c60
RAM: 4G
So could you test with Multiprocess disabled: https://wiki.mozilla.org/Electrolysis#Firefox_Release (restart FF to apply)

Is it better?
I did set browser.tabs.remote.autostart.2 to false(was set to true)

It is much better.
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:53.0) Gecko/20100101 Firefox/53.0

I have tested this issue on Windows 10 x64 and x86 with the latest Firefox(50.0) and the latest Nightly (53.0a1-20161122030216) with e10s enabled/disabled.
On Firefox(50.0) with e10s enabled the issue is reproducible. Having opened multiple tabs(~45), when switching from one tab to another you can observe the spinning circle into the main window for about 2-10s.
On Nightly (53.0a1-20161122030216) with e10s enabled/disabled and Firefox(50.0) with e10s disabled, the issue is not reproducible.

Can you please retest this using the latest Nightly build (https://nightly.mozilla.org/) and report back the results?
Status: UNCONFIRMED → NEW
Component: Untriaged → Tabbed Browser
Ever confirmed: true
Flags: needinfo?(foxb)
I've installed nightly version:
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:53.0) Gecko/20100101 Firefox/53.0

When I enable multi process I've noticed turning circle on main window only once and just for few seconds. The browser itself looks to be slower and takes much more time to load the tabs. (but that could be just my ISP)

With multi process disabled I did not notice the issue.
Flags: needinfo?(foxb)
(In reply to Hristo from comment #6)
> I've installed nightly version:
> Mozilla/5.0 (Windows NT 10.0; WOW64; rv:53.0) Gecko/20100101 Firefox/53.0
> 
> When I enable multi process I've noticed turning circle on main window only
> once and just for few seconds. The browser itself looks to be slower and
> takes much more time to load the tabs. (but that could be just my ISP)
> 
> With multi process disabled I did not notice the issue.

Interesting. And you're also able to reproduce this behaviour on Nightly in Safe Mode? (I know you were able to reproduce on Release in Safe Mode).
Flags: needinfo?(foxb)
Yes it is reporoducible when multiprocess is enabled.
Build: 	20161125030214
Flags: needinfo?(foxb)
Very interesting - being able to reproduce on Nightly with all of your add-ons disabled (Safe Mode) is very strange.

Would you be able to attach the text from about:support? There's a button on that page to copy the text to your clipboard.
Flags: needinfo?(foxb)
Hereis the data in safe mode

Application Basics
------------------

Name: Firefox
Version: 53.0a1
Build ID: 20161125030214
Update Channel: nightly
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:53.0) Gecko/20100101 Firefox/53.0
OS: Windows_NT 10.0
Multiprocess Windows: 1/1 (Enabled by user)
Safe Mode: true

Crash Reports for the Last 3 Days
---------------------------------

All Crash Reports

Extensions
----------

Name: Application Update Service Helper
Version: 1.0
Enabled: true
ID: aushelper@mozilla.org

Name: FlyWeb
Version: 1.0.0
Enabled: true
ID: flyweb@mozilla.org

Name: Form Autofill
Version: 1.0
Enabled: true
ID: formautofill@mozilla.org

Name: Multi-process staged rollout
Version: 1.6
Enabled: true
ID: e10srollout@mozilla.org

Name: Pocket
Version: 1.0.5
Enabled: true
ID: firefox@getpocket.com

Name: Presentation
Version: 1.0.0
Enabled: true
ID: presentation@mozilla.org

Name: Web Compat
Version: 1.0
Enabled: true
ID: webcompat@mozilla.org

Name: Adblock Plus
Version: 2.8.2
Enabled: false
ID: {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}

Graphics
--------

Features
Compositing: Basic
Asynchronous Pan/Zoom: wheel input enabled; touch input enabled
WebGL Renderer: WebGL is currently disabled.
WebGL2 Renderer: WebGL is currently disabled.
Hardware H264 Decoding: No; Hardware video decoding disabled or blacklisted
Audio Backend: wasapi
DirectWrite: true (10.0.14393.351)
GPU #1
Active: Yes
Description: AMD Radeon HD 6290 Graphics
Vendor ID: 0x1002
Device ID: 0x9807
Driver Version: 15.201.1151.0
Driver Date: 8-21-2015
Drivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
Subsys ID: 05981025
RAM: 256

Diagnostics
AzureCanvasAccelerated: 0
AzureCanvasBackend: skia
AzureContentBackend: skia
AzureFallbackCanvasBackend: cairo
Decision Log
HW_COMPOSITING:
blocked by runtime: Acceleration blocked by safe-mode
D3D11_COMPOSITING:
unavailable by default: Hardware compositing is disabled
D3D9_COMPOSITING:
unavailable by default: Hardware compositing is disabled
DIRECT2D:
unavailable by default: Direct2D requires Direct3D 11 compositing
D3D11_HW_ANGLE:
unavailable by default: D3D11 compositing is disabled
disabled by env: D3D11 compositing is disabled
GPU_PROCESS:
blocked by runtime: Safe-mode is enabled




Important Modified Preferences
------------------------------

accessibility.typeaheadfind.flashBar: 0
browser.cache.disk.capacity: 358400
browser.cache.disk.filesystem_reported: 1
browser.cache.disk.smart_size.first_run: false
browser.cache.disk.smart_size.use_old_max: false
browser.cache.frecency_experiment: 2
browser.download.importedFromSqlite: true
browser.places.smartBookmarksVersion: 8
browser.sessionstore.upgradeBackup.latestBuildID: 20161125030214
browser.startup.homepage_override.buildID: 20161125030214
browser.startup.homepage_override.mstone: 53.0a1
browser.tabs.remote.autostart: true
browser.tabs.remote.autostart.2: false
browser.urlbar.daysBeforeHidingSuggestionsPrompt: 0
browser.urlbar.lastSuggestionsPromptDate: 20161125
dom.gamepad.extensions.enabled: true
extensions.lastAppVersion: 53.0a1
gfx.crash-guard.d3d11layers.appVersion: 50.0
gfx.crash-guard.d3d11layers.deviceID: 0x9807
gfx.crash-guard.d3d11layers.driverVersion: 15.201.1151.0
gfx.crash-guard.d3d11layers.feature-d2d: true
gfx.crash-guard.d3d11layers.feature-d3d11: true
gfx.crash-guard.status.d3d11layers: 2
media.gmp-eme-adobe.abi: x86-msvc-x64
media.gmp-eme-adobe.lastUpdate: 1479842973
media.gmp-eme-adobe.version: 17
media.gmp-gmpopenh264.abi: x86-msvc-x64
media.gmp-gmpopenh264.lastUpdate: 1479842975
media.gmp-gmpopenh264.version: 1.6
media.gmp-manager.buildID: 20161104212021
media.gmp-manager.lastCheck: 1480131813
media.gmp-widevinecdm.abi: x86-msvc-x64
media.gmp-widevinecdm.lastUpdate: 1479842983
media.gmp-widevinecdm.version: 1.4.8.903
media.gmp.storage.version.observed: 1
media.hardware-video-decoding.failed: false
media.webrtc.debug.log_file: C:\Users\hristo\AppData\Local\Temp\WebRTC.log
network.cookie.prefsMigrated: true
network.predictor.cleaned-up: true
places.database.lastMaintenance: 1480183840
places.history.expiration.transient_current_max_pages: 127211
plugin.disable_full_page_plugin_for_types: application/pdf
plugin.importedState: true
security.sandbox.content.tempDirSuffix: {9d415b09-b5ab-489d-894d-bf4f716eca14}
services.sync.declinedEngines:
services.sync.engine.adblockplus: true
services.sync.engine.addons: false
services.sync.engine.history: false
services.sync.engine.prefs: false
services.sync.engine.tabs: false
services.sync.lastPing: 1480130487
services.sync.lastSync: Sat Nov 26 2016 14:48:28 GMT-0500 (Eastern Standard Time)
services.sync.numClients: 5
storage.vacuum.last.index: 0
storage.vacuum.last.places.sqlite: 1480183828
ui.osk.debug.keyboardDisplayReason: IKPOS: Touch screen not found.

Important Locked Preferences
----------------------------

Places Database
---------------

JavaScript
----------

Incremental GC: true

Accessibility
-------------

Activated: false
Prevent Accessibility: 0

Library Versions
----------------

NSPR
Expected minimum version: 4.13.1
Version in use: 4.13.1

NSS
Expected minimum version: 3.28 Beta
Version in use: 3.28 Beta

NSSSMIME
Expected minimum version: 3.28 Beta
Version in use: 3.28 Beta

NSSSSL
Expected minimum version: 3.28 Beta
Version in use: 3.28 Beta

NSSUTIL
Expected minimum version: 3.28 Beta
Version in use: 3.28 Beta

Experimental Features
---------------------

Sandbox
-------

Content Process Sandbox Level: 2
Flags: needinfo?(foxb)
If I'm interpreting this correctly, this says that your machine currently has 256MB of RAM. Is that correct?
Flags: needinfo?(foxb)
If I read it correctly this amount is for GPU(in Graphics section).
I have 4G of RAM.
Flags: needinfo?(foxb)
(In reply to Hristo from comment #12)
> If I read it correctly this amount is for GPU(in Graphics section).
> I have 4G of RAM.

Ah, thank you, yes, that makes more sense.

Can you give me an example of two tabs that switching back and forth between shows a spinner?
Flags: needinfo?(foxb)
I've started to open new tabs to
h__p://hackedgadgets.com/
h__p://makezine.com/blog/
h__p://lifehacker.com/
h__ps://www.giveawayoftheday.com/

On 4-th I had the spinner and moving back to others also give a spinner for a sec.

After full load of the pages moving between tabs does not produce spinner.

By opening few other tabs and going back to already loaded pages I also get the spinner for a sec.
In summary problem is reproducible under load.
Flags: needinfo?(foxb)
A year later, I can confirm I also see this bug in the latest Nightly 60.0a1 (2018-01-27) (64-bit), Build ID 20180127100319 and in Firefox release (58.0) . 

This is a regression caused by e10s (multi-process Firefox), since disabling multi-process fixes this, by setting browser.tabs.remote.autostart to false in about:config you get immediate tab switch time.

My full observations were reported in Bug 967059 comment 7 (and also comments 4,5) , but this bug is more appropriate for them since they are relevant also for a small number of tabs, and Bug 967059 is about slow tab switch time in the case of a lot of tabs.

In both Nightly and Firefox release (58.0), even with e10s disabled, there is in addition a problem with slow tab switch time when there are a lot of tabs and this is tracked in Bug 967059 .

*) Was tab switch time in the release criteria of e10s ? If yes, how was it shipped without fixing this?
This bug should be marked as blocking Bug 967059
Answering Mike Conley from Bug 967059 comment 9 here, since this bug is more appropriate for the discussion (Bug 967059 is about the case of many tabs):

> I'm completely unable to reproduce the slowness you're describing using the
> steps you provided. My tab switches among those six tabs are immediate.
> 
> nivtwig, since you're able to reproduce this consistently, can you try
> reproducing it in Safe Mode? (Help > Restart with Add-ons Disabled). Does
> that change the performance at all?

I am currently working on another computer and can't reproduce it here with these 6 tabs, tab switches are immediate on the second computer, probably because the CPU/hardware is better on the second computer (probably the reason), or due to a different configuration (I doubt it). However it is reproducible by switching tabs while tabs are loading, or with other, heavier tabs:

*) Open 3 tabs: www.globes.co.il , www.calcalist.co.il , www.ynet.co.il and wait for them to fully load. Switch fast between the tabs by clicking on them randomly.
This was done on a clean profile, no add-ons, with the latest Nightly. An ad-blocker extension (ublock-origin) improves the situation...
If you still can't see that, then reload one tab, or all tabs, and try switching between tabs while the tabs are loading.

*) You can see this also with the original 6 bugzilla tabs in my previous steps to reproduce, by right clicking a tab and selecting "reload all tabs" from the popup menu, and then trying switching between them while tabs are loading.

The second computer hardware (where tab switches seem immediate) is: CPU G2020 2.9GHZ, 12GB memory, SSD (Samsung 850 EVO 250GB), Windows 10 64-bit, and probably a better internal graphics card (Intel Ivy Bridge-DT GT1 HD Graphics 2500)
Some additional information regarding comment 17, about the 3 tabs testcase:

1) When e10s is enabled (the default) tab switch time is slow both in the latest Nightly and Firefox release(58.0.1) . I forgot to mention that it takes sometimes more than 2 seconds for the tabs to switch.

2) When e10s is disabled, everything is ok in both Nightly and Firefox 58.0.1 . Time to switch is immediate in most of the times, apart maybe from intermittent rare cases.

3) When running in safe mode, e10s enabled, in both Nightly and Firefox 58.0.1 , time to switch is improved greatly (but not as with e10s disabled from case 2), surprisingly (when not running in safe mode, there were no add-ons, so I thought it should be the same)

To summarize: with both Nightly and 58.0.1, this is a regression caused by e10s. Disabling e10s fixes it, running in safe mode improves it, but not as when disabling e10s.

*) This should be blocking bug 967059 , and bug 1063169 , Please add dependencies .
Mike Conley or others, I gave a simple and better testcase in comment 17 (a 3 tabs only testcase), after Mike couldn't reproduce my 6 tabs testcase.

Can somebody try and test/confirm this, and triage and give priority ? 
Since it is a regression caused by e10s, I believe it should be given higher priority.
I am unable to reproduce the issue given the 3 tabs testcase that you describe in comment 17. It might very well by hardware dependent.

Are you willing to gather and post a performance profile on the slow hardware using https://developer.mozilla.org/en-US/docs/Mozilla/Performance/Reporting_a_Performance_Problem ?
Flags: needinfo?(nivtwig)
(In reply to Mike Conley (:mconley) (:⚙️) from comment #20)
The profile for the 3 tabs testcase in comment 17, on a Win 10 64-bit computer with intel G41 express graphics chipset : https://perfht.ml/2sjRenV

Note that on this computer "about:support" shows that compositing is basic (not directX), and D3D11_COMPOSITING is 
"Blocklisted due to known issues; bug 1116812", which may cause a slowdown, but with e10s disabled tab switch is much quicker and without jank, most of the time.

On another computer (I don't currently have access to it in order to create a profile) with better CPU and graphics, intel G2020 CPU with internal graphics, the compositing is D3D11, and I still see the problem, and again when disabling e10s it is much better.

about:support graphics section output:

Compositing	Basic
Asynchronous Pan/Zoom	wheel input enabled; scrollbar drag enabled; keyboard enabled; autoscroll enabled
WebGL 1 Driver WSI Info	EGL_VENDOR: Google Inc. (adapter LUID: 0000000000006c81)
EGL_VERSION: 1.4 (ANGLE 2.1.0.db3422764a9b)
EGL_EXTENSIONS: EGL_EXT_create_context_robustness EGL_ANGLE_d3d_share_handle_client_buffer EGL_ANGLE_d3d_texture_client_buffer EGL_ANGLE_surface_d3d_texture_2d_share_handle EGL_ANGLE_query_surface_pointer EGL_ANGLE_window_fixed_size EGL_NV_post_sub_buffer EGL_KHR_create_context EGL_EXT_device_query EGL_KHR_image EGL_KHR_image_base EGL_KHR_gl_texture_2D_image EGL_KHR_gl_renderbuffer_image EGL_KHR_get_all_proc_addresses EGL_ANGLE_flexible_surface_compatibility EGL_ANGLE_create_context_webgl_compatibility EGL_CHROMIUM_create_context_bind_generates_resource EGL_EXT_pixel_format_float EGL_KHR_surfaceless_context EGL_ANGLE_display_texture_share_group EGL_ANGLE_create_context_client_arrays EGL_ANGLE_program_cache_control 
EGL_EXTENSIONS(nullptr): EGL_EXT_client_extensions EGL_EXT_platform_base EGL_EXT_platform_device EGL_ANGLE_platform_angle EGL_ANGLE_platform_angle_d3d EGL_ANGLE_device_creation EGL_ANGLE_device_creation_d3d11 EGL_ANGLE_experimental_present_path EGL_KHR_client_get_all_proc_addresses EGL_ANGLE_display_robust_resource_initialization 
WebGL 1 Driver Renderer	Google Inc. -- ANGLE (Intel(R) G41 Express Chipset (Microsoft Corporation - WDDM 1.1) Direct3D9Ex vs_3_0 ps_3_0)
WebGL 1 Driver Version	OpenGL ES 2.0 (ANGLE 2.1.0.db3422764a9b)
WebGL 1 Driver Extensions	GL_ANGLE_client_arrays GL_ANGLE_depth_texture GL_ANGLE_framebuffer_blit GL_ANGLE_framebuffer_multisample GL_ANGLE_instanced_arrays GL_ANGLE_pack_reverse_row_order GL_ANGLE_program_cache_control GL_ANGLE_request_extension GL_ANGLE_robust_client_memory GL_ANGLE_robust_resource_initialization GL_ANGLE_texture_compression_dxt3 GL_ANGLE_texture_compression_dxt5 GL_ANGLE_texture_usage GL_ANGLE_translated_shader_source GL_CHROMIUM_bind_generates_resource GL_CHROMIUM_bind_uniform_location GL_CHROMIUM_color_buffer_float_rgb GL_CHROMIUM_color_buffer_float_rgba GL_CHROMIUM_copy_texture GL_CHROMIUM_sync_query GL_EXT_blend_minmax GL_EXT_color_buffer_half_float GL_EXT_debug_marker GL_EXT_frag_depth GL_EXT_occlusion_query_boolean GL_EXT_read_format_bgra GL_EXT_robustness GL_EXT_shader_texture_lod GL_EXT_texture_compression_dxt1 GL_EXT_texture_filter_anisotropic GL_EXT_texture_format_BGRA8888 GL_EXT_texture_storage GL_EXT_unpack_subimage GL_KHR_debug GL_NV_fence GL_NV_pack_subimage GL_OES_EGL_image GL_OES_EGL_image_external GL_OES_depth32 GL_OES_element_index_uint GL_OES_get_program_binary GL_OES_packed_depth_stencil GL_OES_rgb8_rgba8 GL_OES_standard_derivatives GL_OES_surfaceless_context GL_OES_texture_float GL_OES_texture_half_float GL_OES_texture_half_float_linear GL_OES_texture_npot GL_OES_vertex_array_object 
WebGL 1 Extensions	ANGLE_instanced_arrays EXT_blend_minmax EXT_color_buffer_half_float EXT_frag_depth EXT_shader_texture_lod EXT_texture_filter_anisotropic OES_element_index_uint OES_standard_derivatives OES_texture_float OES_texture_half_float OES_texture_half_float_linear OES_vertex_array_object WEBGL_color_buffer_float WEBGL_compressed_texture_s3tc WEBGL_debug_renderer_info WEBGL_debug_shaders WEBGL_depth_texture WEBGL_lose_context
WebGL 2 Driver WSI Info	-
WebGL 2 Driver Renderer	WebGL creation failed: 
* Error during ANGLE OpenGL init.
* Exhausted GL driver caps.
WebGL 2 Driver Version	-
WebGL 2 Driver Extensions	-
WebGL 2 Extensions	-
Direct2D	Blocked for your graphics card because of unresolved driver issues.
Off Main Thread Painting Enabled	true
DirectWrite	true (10.0.16299.15)
GPU #1
Active	Yes
Description	Intel(R) G41 Express Chipset (Microsoft Corporation - WDDM 1.1)
Vendor ID	0x8086
Device ID	0x2e32
Driver Version	8.15.10.2702
Driver Date	3-11-2013
Drivers	igdumd64 igd10umd64 igdumd32 igd10umd32
Subsys ID	00000000
RAM	Unknown
Diagnostics
AzureCanvasAccelerated	0
AzureCanvasBackend (UI Process)	skia
AzureContentBackend (UI Process)	skia
AzureFallbackCanvasBackend (UI Process)	cairo
GPUProcessPid	7832
GPUProcess	
Device Reset	
Decision Log
D3D11_COMPOSITING	
Blocklisted due to known issues; bug 1116812
DIRECT2D	
unavailable by default: Direct2D requires Direct3D 11 compositing
D3D11_HW_ANGLE	
unavailable by default: D3D11 compositing is disabled
disabled by env: D3D11 compositing is disabled
WEBRENDER	
opt-in by default: WebRender is an opt-in feature
unavailable by runtime: ANGLE is disabled
Flags: needinfo?(nivtwig)
Flags: needinfo?(mconley)
(In reply to nivtwig from comment #21)
> (In reply to Mike Conley (:mconley) (:⚙️) from comment #20)
> The profile for the 3 tabs testcase in comment 17, on a Win 10 64-bit
> computer with intel G41 express graphics chipset : https://perfht.ml/2sjRenV

I submitted a performance profile 13 days ago, can anybody have a look at it ?
Hi nivtwig,

I see a pretty encumbered compositor thread... lots of missing samples in there, making me think the machine was under pretty heavy load, or is having trouble handling the amount of things we're asking it to do here.

You've mentioned a number of different computers having different computers. Let's try to keep things focused to a single computer - the one that you've gathered this profile from.

Can you give me the specs for that machine?
Flags: needinfo?(mconley) → needinfo?(nivtwig)
(In reply to Mike Conley (:mconley) (:⚙️) (Totally backlogged on reviews and needinfos) from comment #23)

> You've mentioned a number of different computers having different computers.
> Let's try to keep things focused to a single computer - the one that you've
> gathered this profile from.
> 
> Can you give me the specs for that machine?

Motherboard: ASUS P5G41T-M LX (with Intel G41 graphics)
CPU: Intel Pentium Dual Core E6700 3.2GHz
Drive: SanDisk SDSSDA240G 
Memory: 6GB DDR3
OS: Windows 10 64-bit
Flags: needinfo?(nivtwig)
(In reply to nivtwig from comment #24)

Can you go to about:preferences, find the Performance section, and uncheck "Use recommended performance settings", and then set the Content Process limit to 2 instead? Does that impact the tab switching after a restart?
Flags: needinfo?(foxb)
Whoops - ni?'d the wrong person.
Flags: needinfo?(foxb) → needinfo?(nivtwig)
(In reply to Mike Conley (:mconley) (:⚙️) (Totally backlogged on reviews and needinfos) from comment #25)
> (In reply to nivtwig from comment #24)
> 
> Can you go to about:preferences, find the Performance section, and uncheck
> "Use recommended performance settings", and then set the Content Process
> limit to 2 instead? Does that impact the tab switching after a restart?

It is hard to tell.
Firstly, with 4 content processes (the default), I think there was an improvement since the last time I checked, the small hangs when switching tabs are less frequent than before. This might be caused by improvements in Nightly, or by changes in the web sites or ads.
When using 2 content processes, I think there is some improvement in the frequency of the slow tab switches, but I can still see them from time to time.
And again, when e10s is disabled, it is better than with 2 content processes, tab switches are faster and slow tab switches are very rare.
Flags: needinfo?(nivtwig)
Okay, and how about 1 content process?
Flags: needinfo?(nivtwig)
(In reply to Mike Conley (:mconley) (:⚙️) (Totally backlogged on reviews and needinfos) from comment #28)
> Okay, and how about 1 content process?

Again, it is hard to tell between 1 and 2 content processes . When clicking randomly to switch the tabs, there are some slow tab switches from time to time, but most of the times the tab switch is ok.
Since there was an improvement in all cases (4,2,1 content processes) since the last time I checked, maybe there is a need for a better testcase where it is more apparent.

Note that Bug 1063169 has some blocking bugs about slow tab switch due to e10s, that might be related, and maybe help with this bug if they get fixed ...:
Bug 1176007, Bug 1180916, Bug 1181333, Bug 1135719
Flags: needinfo?(nivtwig)
Severity: normal → S3

Reporter, is this still an issue?

Flags: needinfo?(foxb)

(In reply to Gregory Pappas [:greg] from comment #30)

Reporter, is this still an issue?

HI,

I do not see the issue anymore. Thanks for the improvement. Issue can be closed.

Flags: needinfo?(foxb)

(In reply to Hristo from comment #31)

I do not see the issue anymore. Thanks for the improvement. Issue can be closed.

Great to hear!

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.