Closed Bug 1318972 Opened 5 years ago Closed 5 years ago

Custom keyboard shortcut Ctrl + , not working

Categories

(Core :: Widget: Win32, defect)

50 Branch
x86_64
Windows 10
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Tracking Status
firefox50 --- wontfix
firefox51 --- wontfix
firefox52 --- fixed
firefox53 --- unaffected

People

(Reporter: bartek.wodyk, Unassigned)

References

Details

(Keywords: inputmethod, regression)

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20161104212021

Steps to reproduce:

I have assigned some emoji unicodes to my keyboard layout on Windows 10. Since either version 49 or 50 one of the shortcuts stopped working. When pressing Ctrl + , the assigned emoji does not appear on the screen. This only happens in Firefox and only with that one custom shortcut. The others are working.


Actual results:

Nothing appears on the screen.


Expected results:

A unicode symbol emoji should come up.
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64
Component: Untriaged → Keyboard: Navigation
Product: Firefox → Core
Is it possible to test that with Windows 7? If yes, could you provide steps to reproduce (about binding shortcut for emoji)
Flags: needinfo?(bartek.wodyk)
Yes, it should be possible. I have created a keyboard layout for my personal use. The layout has been generated by MSKLC and it has emojis assigned to:
Ctrl + , 
Ctrl + . 
Ctrl + / 
Ctrl + ; 
Ctrl + '

Download: https://drive.google.com/open?id=0B62evFR3C081OEpHMGxUS0p2MDA

After installing you might need to change the keyboard layout to Polish/Polski (bartek - emoji) in Control Panel. If you don't trust exes from strangers then you can create your own layout using MSKLC by downloading it from here: https://msdn.microsoft.com/en-us/globalization/keyboardlayouts.aspx
The shortcut is for your physical keyboard or Windows on-screen keyboard?
Physical keyboard but works with on-screen as well.
Well, on Win 7, emojis are available with an update but the user can't type on OSK to write emojis (only copy/paste from emojis data base e.g.).

As you are able to reproduce the issue, could you download the tool Mozregression to narrow down a regression range in FF49 or 50.
See http://mozilla.github.io/mozregression/ for details.
Run the command "mozregression --good=48" then copy here the final pushlog.
I use 32bit builds on 64bit OS. CLI version tested 64bit builds and something went wrong. I got further with 32bit testing.

Testing 64bit builds:
http://pastebin.com/hRRFuJ9s

Testing 32bit builds:
http://pastebin.com/Rhnhfc0E
You can specify bits with command --bits=32/64. But sometimes, some bugs appear in the 32b version, not in the 64b version and vice versa. Thanks for the reg range.
Reg range:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=6795225dc65f98d2c5007e1bf8e0b7ffb2265e38&tochange=0770506cb101cb2a70d0e4d267361767a9bfc9b6

 	
Masayuki, could you check this regression after your patches in bug 1293505.
Blocks: 1293505
Status: UNCONFIRMED → NEW
Component: Keyboard: Navigation → Widget: Win32
Ever confirmed: true
Flags: needinfo?(bartek.wodyk) → needinfo?(masayuki)
> tracking-firefox50: --- → ?
> status-firefox50: --- → affected
> tracking-firefox51: --- → ?
> status-firefox51: --- → affected
> tracking-firefox52: --- → ?
> status-firefox52: --- → affected
> tracking-firefox53: --- → ?

Are you really sure? I can reproduce this bug only 50 and 51 on Win10. At 52, we've already landed the patches for bug 1300003 and bug 1303273 which must fix this kind of bugs completely.

The patches are too risky to uplift. So, I won't fix this bug at 50.0.x nor 51.
Flags: needinfo?(masayuki)
It was just a guess, let's remove the flags fo these versions.
Okay, then, let's mark this as fixed at 52.
Status: NEW → RESOLVED
Closed: 5 years ago
Depends on: 1303273
Resolution: --- → FIXED
bartek.wodyk:

Sorry for the inconvenience until releasing 52. If you use Firefox Developer Edition (it's currently 52), you can type any character with any custom keyboard layout. If you don't mind to use it, I'd like to recommend to use it: https://www.mozilla.org/en-US/firefox/developer/

Note that you can switch the theme from Dark to Light from Customizing UI of toolbar. And you can sync both Profiles for Firefox (Release) and Firefox Developer Edition with "Firefox Sync" (https://support.mozilla.org/en-US/kb/how-do-i-set-sync-my-computer). Or just uncheck "Allow Firefox Developer Edition and Firefox to run at the same time" in "General" of Options.
Ok, thanks. I guess it's good to know that the issue is fixed in FF 52. I'd use Dev edition, since I use the dark theme anyway, but I rely on Polish spell check and the only way I've found to keep Polish spell check and English UI is to use the Polish version of FF and apply the English language pack on top. Otherwise with every update I need to mess about with dictionary files.
Scrap that. All working well with 52.0a2en-GB and force installed Polish dictionary. Thanks again. :)
You need to log in before you can comment on or make changes to this bug.