Update ANGLE to chromium/2924

RESOLVED FIXED in Firefox 51

Status

()

defect
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: ethlin, Assigned: ethlin)

Tracking

unspecified
mozilla53
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox50 wontfix, firefox51 fixed, firefox52 fixed, firefox53 fixed)

Details

()

Attachments

(3 attachments, 3 obsolete attachments)

The new ANGLE fixes some crash problems and conformance tests. The latest version is 2924 and I'll update it.
Posted patch Part1. Update ANGLE/2924 (obsolete) — Splinter Review
Update to ANGLE/2924.
Attachment #8813532 - Flags: review?(jgilbert)
We had workaround in ReadPixels for ANGLE. It seems like we don't need the workaround anymore since ANGLE has some fixes, like [1], [2].

[1] https://github.com/google/angle/commit/0a337e93bf945dc76d8d4f77912ea00e25986bb3
[2] https://github.com/google/angle/commit/ece7c5a848df6b64e361184bbf3a9739b209e40c
Comment on attachment 8813532 [details] [diff] [review]
Part1. Update ANGLE/2924

Review of attachment 8813532 [details] [diff] [review]:
-----------------------------------------------------------------

Yes, I /totally/ reviewed this whole cset. :)
Attachment #8813532 - Flags: review?(jgilbert) → review+
Remove some files from UNIFIED_SOURCES which are not compatible with unified build.
Attachment #8813542 - Flags: review?(mtseng)
Fix build break on windows for ANGLE.
Attachment #8813552 - Flags: review?(mtseng)
Attachment #8813532 - Attachment description: Update ANGLE/2924 → Part1. Update ANGLE/2924
Attachment #8813539 - Attachment description: Fix try crash problem → Part2. Fix try crash problem
Attachment #8813542 - Attachment description: Fix angle build script → Fix angle build script (for mozilla/angle)
Attachment #8813552 - Attachment description: Fix build break after angle update → Fix build break after angle update (for mozilla/angle)
(In reply to Ethan Lin[:ethlin] from comment #5)
> Created attachment 8813552 [details] [diff] [review]
> Fix build break after angle update (for mozilla/angle)
> 
> Fix build break on windows for ANGLE.

try result of the build break:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=5eb322f99df7f89f48c32f4ed9eff53b1f96ecc7&selectedJob=31551538
Per dicussion with Morris, we just need this fix.
Attachment #8813542 - Attachment is obsolete: true
Attachment #8813552 - Attachment is obsolete: true
Attachment #8813542 - Flags: review?(mtseng)
Attachment #8813552 - Flags: review?(mtseng)
Attachment #8813593 - Flags: review?(mtseng)
Attachment #8813539 - Flags: review?(jgilbert)
Upload new patch due the change of ANGLE/gyp_mozbuild.
Attachment #8813532 - Attachment is obsolete: true
milan, we would like to land this in central this week. If everything goes well, we would like to uplift this to aurora/beta. Do you have any concern?
Flags: needinfo?(milan)
Attachment #8813593 - Flags: review?(mtseng) → review+
(In reply to Peter Chang[:pchang] from comment #10)
> milan, we would like to land this in central this week. If everything goes
> well, we would like to uplift this to aurora/beta. Do you have any concern?

Well, it is somewhat scary, but let's land it on central this week, aurora early next week, and beta towards the end of the week following, assuming nothing bad shows up.
Flags: needinfo?(milan)
Attachment #8813539 - Flags: review?(jgilbert) → review?(mtseng)
Attachment #8813539 - Flags: review?(mtseng) → review+
https://hg.mozilla.org/mozilla-central/rev/fcf8c42bf382
https://hg.mozilla.org/mozilla-central/rev/797ee4b5a948
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
I'm experiencing this compile failure:

c:/t1/hg/comm-central/mozilla/gfx/angle/src/libANGLE/renderer/Format_table_autogen.cpp(28): error C2131: expression did not evaluate
 to a constant
c:\t1\hg\comm-central\mozilla\gfx\angle\src\libANGLE/renderer/Format.h(81): note: a non-constant (sub-)expression was encountered
c:/t1/hg/comm-central/mozilla/gfx/angle/src/libANGLE/renderer/Format_table_autogen.cpp(149): fatal error C1903: unable to recover fr
om previous error(s); stopping compilation
c:/t1/hg/comm-central/mozilla/config/rules.mk:963: recipe for target 'Unified_cpp_angle_src_libANGLE9.obj' failed
mozmake[4]: *** [Unified_cpp_angle_src_libANGLE9.obj] Error 2

Any hints?
more context

c:/t1/hg/comm-central/mozilla/gfx/angle/src/libANGLE/renderer/Format_table_autogen.cpp(28): error C2131: expression did not evaluate
 to a constant
c:\t1\hg\comm-central\mozilla\gfx\angle\src\libANGLE/renderer/Format.h(81): note: a non-constant (sub-)expression was encountered
c:/t1/hg/comm-central/mozilla/gfx/angle/src/libANGLE/renderer/Format_table_autogen.cpp(149): fatal error C1903: unable to recover fr
om previous error(s); stopping compilation
c:/t1/hg/comm-central/mozilla/config/rules.mk:963: recipe for target 'Unified_cpp_angle_src_libANGLE9.obj' failed
mozmake[4]: *** [Unified_cpp_angle_src_libANGLE9.obj] Error 2
mozmake[4]: *** Waiting for unfinished jobs....
Looks like I need VS 2015 Update 3
I only have Update 3
note to self:
The "correct" fix is of course to use a better compiler but VS2015 is a supported target so the correct fix would be to make all of these jump tables static const instead of constexpr.
Depends on: 1320471
FYI, bug 1319901 tracks enforcing Update 3 as the minimum version supported.

Ethan, it looks like we need to backport this to at least Aurora52. Do we need to go back further than that? Please nominate accordingly.
Flags: needinfo?(ethlin)
Flags: needinfo?(ethlin)
Summary: Update to ANGLE/2924 → Update ANGLE to chromium/2924
(In reply to Philip Chee from comment #17)
> Looks like I need VS 2015 Update 3
> I only have Update 3

Sorry, which version do you have that *doesn't* work? I assume u2?


We should take a stab at getting this building with u2 before uplifting to Aurora.
Flags: needinfo?(philip.chee)
Blocks: 1315979
(In reply to Ryan VanderMeulen [:RyanVM] from comment #19)
> FYI, bug 1319901 tracks enforcing Update 3 as the minimum version supported.
> 
> Ethan, it looks like we need to backport this to at least Aurora52. Do we
> need to go back further than that? Please nominate accordingly.

Yes, we need this for Aurora and uplift to beta51 few days later if no bad things happen.

(In reply to Jeff Gilbert [:jgilbert] from comment #20)
> (In reply to Philip Chee from comment #17)
> > Looks like I need VS 2015 Update 3
> > I only have Update 3
> 
> Sorry, which version do you have that *doesn't* work? I assume u2?
> 
> 
> We should take a stab at getting this building with u2 before uplifting to
> Aurora.
I'm building this patch with 2015u2 and will update later.
I got the same error in comment 16 with 20155u2.
Comment on attachment 8813597 [details] [diff] [review]
Part1. Update ANGLE/2924 (carry r+: jgilbert)

Approval Request Comment
[Feature/Bug causing the regression]: webgl2
[User impact if declined]: some webgl api may malfunction
[Is this code covered by automated tests?]: yes
[Has the fix been verified in Nightly?]: yes
[Needs manual test from QE? If yes, steps to reproduce]: no 
[List of other uplifts needed for the feature/fix]:
[Is the change risky?]: no
[Why is the change risky/not risky?]: newer ANGLE should fix some bugs
[String changes made/needed]: none
Attachment #8813597 - Flags: approval-mozilla-aurora?
Comment on attachment 8813539 [details] [diff] [review]
Part2. Fix try crash problem

Approval Request Comment
[Feature/Bug causing the regression]: webgl2
[User impact if declined]: some webgl api may malfunction
[Is this code covered by automated tests?]: yes
[Has the fix been verified in Nightly?]: yes
[Needs manual test from QE? If yes, steps to reproduce]: no 
[List of other uplifts needed for the feature/fix]:
[Is the change risky?]: no
[Why is the change risky/not risky?]: newer ANGLE should fix some bugs
[String changes made/needed]: none
Attachment #8813539 - Flags: approval-mozilla-aurora?
I had VS2015 Update 2. Didn't work Updated to VS2015 Update 3. Compiles ANGLE fine.
Flags: needinfo?(philip.chee)
Comment on attachment 8813597 [details] [diff] [review]
Part1. Update ANGLE/2924 (carry r+: jgilbert)

ANGLE update for aurora52.  wcpgw.
Attachment #8813597 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Comment on attachment 8813539 [details] [diff] [review]
Part2. Fix try crash problem

remove workaround for ANGLE bug after updating it, for aurora52
Attachment #8813539 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Blocks: 1321094
Duplicate of this bug: 1313875
Ryan, we would like to uplift patches in Comment 28 to beta51. I made a patch in bug 1321094 attachment 8815609 [details] to fix compiler error with VS2015u2. I got build passed in my local. But I'm not sure how could I make sure it works for beta. Any suggestion?
Flags: needinfo?(ryanvm)
The choice of compiler we use to build with is actually controlled via in-tree manifests these days. You should be able to push your patch to Try on top of Beta have things Just Work.
Flags: needinfo?(ryanvm)
The compiler problem for beta was solved and I didn't hear negative things from aurora channel about new ANGLE update.
Comment on attachment 8813597 [details] [diff] [review]
Part1. Update ANGLE/2924 (carry r+: jgilbert)

Approval Request Comment
[Feature/Bug causing the regression]: webgl2
[User impact if declined]: some webgl api may malfunction
[Is this code covered by automated tests?]: yes
[Has the fix been verified in Nightly?]: yes
[Needs manual test from QE? If yes, steps to reproduce]: no 
[List of other uplifts needed for the feature/fix]:
[Is the change risky?]: no
[Why is the change risky/not risky?]: newer ANGLE should fix some bugs
[String changes made/needed]: none
Attachment #8813597 - Flags: approval-mozilla-beta?
Comment on attachment 8813539 [details] [diff] [review]
Part2. Fix try crash problem

Approval Request Comment
[Feature/Bug causing the regression]: webgl2
[User impact if declined]: some webgl api may malfunction
[Is this code covered by automated tests?]: yes
[Has the fix been verified in Nightly?]: yes
[Needs manual test from QE? If yes, steps to reproduce]: no 
[List of other uplifts needed for the feature/fix]:
[Is the change risky?]: no
[Why is the change risky/not risky?]: newer ANGLE should fix some bugs
[String changes made/needed]: none
Attachment #8813539 - Flags: approval-mozilla-beta?
Comment on attachment 8813539 [details] [diff] [review]
Part2. Fix try crash problem

WebGL 2 will be shipped in 51. Angle update is important to this. Beta51+. Should be in 51 beta 8.
Attachment #8813539 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Attachment #8813597 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.