Allow plugin infobar shown when site checks for presence of plugin

RESOLVED DUPLICATE of bug 1186948

Status

()

Core
Plug-ins
RESOLVED DUPLICATE of bug 1186948
2 years ago
a year ago

People

(Reporter: ted, Unassigned)

Tracking

({dev-doc-needed, site-compat})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
I'm seeing a plugin infobar on buzilla.mozilla.org where I never used to see one that says 'Allow https://bugzilla.mozilla.org to run "Adobe Flash"?'

mconley says this might be due to the new hidden plugin stuff, and bugzilla is checking navigator.plugins to see whether it should use Flash for clipboard support. I don't think we should be showing an infobar in this situation.
Created attachment 8812812 [details]
Minified code in Bugzilla that is accessing navigator.plugins["Shockwave Flash"]

This is because there's a script ("extensions/BugModal/web/ZeroClipboard/ZeroClipboard.min.js") on the page accessing navigator.plugins["Shockwave Flash"] directly.

I believe this is a regression from the patch in bug 1308677 - specifically the part that added the CtP fallback state for the nsIPluginTag for Flash.

Under the "hidden Flash plugin" model we're going with via plugins.navigator.hidden_ctp_plugin, do we have a clear sense of how we want to behave here when page script accesses navigator.plugins["Shockwave Flash"] directly?
ni?ing blassey for comment 1.
Flags: needinfo?(blassey.bugs)
I think this is exactly the desired behavior. If the page touches navigator.plugins["Shockwave Flash"], we want that to be null such that fall back code runs:

if (navigator.plugins["Shockwave Flash"]) {
   // fallback code
} else {
   // use flash
}

The original intent of this was to force pages to give us fallback content instead of using flash, but give the users the ability to enable flash if that results in a non-functional page.
Flags: needinfo?(blassey.bugs)
(In reply to Brad Lassey [:blassey] (use needinfo?) from comment #3)
> The original intent of this was to force pages to give us fallback content
> instead of using flash, but give the users the ability to enable flash if
> that results in a non-functional page.

Unfortunately, there are a bunch of sites that seem to check for Flash even if they don't use it - for example, the Google homepage.

bsmedberg and I chatted briefly about this notification bar in Hawaii. I'm personally worried that we're spamming our Nightly users too much with this thing, and that we need an alternative UI (perhaps a new type of charm in the URL bar, similar to the tracking protection one?).
The notification bar appears at the same time as the plugin (lego) icon is displayed in the awesomebar and the latter provides a non-intrusive way to enable the plugin. I don't remember the details about when the notification bar is displayed, but my understanding is that the permission icon will always be present. Perhaps we could fine tune the notification bar heuristics to not appear in some of these cases?

Or maybe we should reconsider the importance of displaying the notification bar if we are serious about killing flash.
:asa reports this is happening on bmo when the ask for permission to run flash bit has been flipped.

Since we're turning on a feature in nightly to force this check, should I be prioritizing removing the places where we check for flash in javascript?
Flags: needinfo?(past)
Keywords: dev-doc-needed, site-compat
I'd advise changing the infobar to indicate that the site might not actually be trying to use flash.
Removing these checks from bmo sounds good to me.
Flags: needinfo?(past)

Comment 9

a year ago
We will be turning this feature off when we turn CtP on for nightly.
(In reply to Panos Astithas [:past] (please needinfo?) from comment #8)
> Removing these checks from bmo sounds good to me.

From Firefox's point of view, I guess we are. However, the problem I wish to raise is all of the *other* sites that will be impacted by this. The door-hanger indicates flash is in use, when in fact it is not. I would suggest saying "This page may need flash, unblock flash?" or something along those lines.
Flags: needinfo?(past)
(In reply to Benjamin Smedberg [:bsmedberg] from comment #9)
> We will be turning this feature off when we turn CtP on for nightly.

So the door hanger goes away? Or what do you mean?
(In reply to Dylan Hardison [:dylan] (he/him) from comment #11)
> (In reply to Benjamin Smedberg [:bsmedberg] from comment #9)
> > We will be turning this feature off when we turn CtP on for nightly.
> 
> So the door hanger goes away? Or what do you mean?
Flags: needinfo?(past) → needinfo?(benjamin)

Comment 13

a year ago
Hiding Flash from navigator.plugins and the related doorhanger *on checking navigator.plugins* is going to be disabled when we mark Flash as click-to-play. The feature was enabled on purpose (bug 1186948) before now.

In any case this is a nightly-only that everyone agreed wasn't ready to ride the trains.
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(benjamin)
Resolution: --- → DUPLICATE
Duplicate of bug: 1186948
You need to log in before you can comment on or make changes to this bug.