Closed Bug 1319410 Opened 5 years ago Closed 4 months ago

View source: don't error-highlight comments with dashes

Categories

(Core :: DOM: HTML Parser, defect, P3)

defect

Tracking

()

RESOLVED FIXED
93 Branch
Tracking Status
firefox53 --- wontfix
firefox93 --- fixed

People

(Reporter: zcorpan, Assigned: hsivonen)

References

Details

Attachments

(3 files)

Henri, can you take a look here?
Flags: needinfo?(hsivonen)
Priority: -- → P3
I'll take a look. Keeping myself needinfoed to keep this visible.
Assignee: nobody → hsivonen
Assignee: hsivonen → nobody
Duplicate of this bug: 1541853

The patch needs to be refreshed with the results of https://github.com/validator/htmlparser/pull/18 before landing.

Flags: needinfo?(hsivonen)
Assignee: nobody → hsivonen
Status: NEW → ASSIGNED
Pushed by hsivonen@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5b33e3f54b58
Make consecutive hyphens in comments a non-error r=smaug
https://hg.mozilla.org/integration/autoland/rev/0b241b7f07e9
fixup - Stay in the COMMENT_LESSTHAN state, annotate fall-throughs. r=smaug
https://hg.mozilla.org/integration/autoland/rev/d75852f907a6
test - "--" in a comment is non-error but "<!--" in a comment is an error. r=smaug
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → 93 Branch
Regressions: 1726374
You need to log in before you can comment on or make changes to this bug.