Closed Bug 1319512 Opened 3 years ago Closed 2 years ago

Disable non-standard expression closure on nightly-only

Categories

(Core :: JavaScript Engine, defect, P3)

defect

Tracking

()

RESOLVED FIXED
mozilla59
Tracking Status
firefox59 --- fixed

People

(Reporter: arai, Assigned: evilpie)

References

Details

(Keywords: dev-doc-complete, site-compat, triage-deferred)

Attachments

(2 files)

Just like bug 1293305, we could disable it only on nightly, with runtime flag,
and keep tests working with testing function to enable it (enableExprClosure).

some tests that want to test expression closure should call enableExprClosure,
and other tests that don't need expression closure should be rewritten in bug 1313490.
Depends on: 1335400
Keywords: site-compat
Keywords: triage-deferred
Priority: -- → P3
Assignee: nobody → evilpies
Attachment #8928478 - Flags: review?(jdemooij)
Attachment #8928478 - Flags: review?(jdemooij) → review+
Comment on attachment 8928479 [details] [diff] [review]
Adjust expression closure tests so they fail

Review of attachment 8928479 [details] [diff] [review]:
-----------------------------------------------------------------

Great we can turn this off finally. We just need to remember to remove these tests when we remove expression closures.

::: js/src/tests/js1_8_5/reflect-parse/expressionClosures.js
@@ +1,1 @@
> +// |reftest| skip-if(!xulRuntime.shell) skip-if(!release_or_beta)

Does this work or should it be:

// |reftest| skip-if(!xulRuntime.shell || !release_or_beta)
Attachment #8928479 - Flags: review?(jdemooij) → review+
Duplicate of this bug: 1335400
Pushed by evilpies@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/261ebf2e8bbd
Disable expression closures on Nightly. r=jandem
https://hg.mozilla.org/integration/mozilla-inbound/rev/8d8aeee2633f
Adjust expression closure tests. r=jandem
https://hg.mozilla.org/mozilla-central/rev/261ebf2e8bbd
https://hg.mozilla.org/mozilla-central/rev/8d8aeee2633f
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
Tom, what do you want to do here on beta/release? Our options are:

(1) Disable expression closures unconditionally on Nightly so this will ride the trains.
(2) Uplift a patch after the merge.
(3) Disable expression closures on beta 58 (too late for that now I guess).
(4) Remove expression closures on Nightly.

I don't care too much, but we should do one of these so this will stay disabled on beta.
Flags: needinfo?(evilpies)
Let's go with 1.
Flags: needinfo?(evilpies)
Blocks: 1426519
You need to log in before you can comment on or make changes to this bug.