Thunderbird shows "Attaching..." during long wait in compose, with no attachments

RESOLVED DUPLICATE of bug 532395

Status

Thunderbird
Message Compose Window
RESOLVED DUPLICATE of bug 532395
a year ago
a year ago

People

(Reporter: Mark Manning, Unassigned)

Tracking

({perf})

45 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20151203163240

Steps to reproduce:

I clicked on the "Reply" icon. While I was composing my email I began to notice that Thunderbird was freezing up and then would continue. At the bottom of the window where I was composing I kept noticing it saying "Attaching..." Only - I did not have any files to attach. The ORIGINAL message I was responding to had two PDFs attached to it but they were not being forwarded or attached. Also, no attachment window opened in the upper right of the screen. Thunderbird hung for approximately one minute and did not come back until I left-single-clicked where I had been typing. Then the hour glass showed up followed almost immediately by Thunderbird working again.


Actual results:

Sorry, I put everything in the first pane.


Expected results:

Thunderbird should not have tried to attach anything until I had clicked on the "Attach" icon. It was not that large of an email.
(Reporter)

Updated

a year ago
Severity: normal → minor
Keywords: hang
OS: Unspecified → Windows XP
Hardware: Unspecified → x86

Updated

a year ago
Severity: minor → normal
Keywords: hang → perf
Summary: Thunderbird hangs under XP → Thunderbird shows "Attaching..." during long wait in compose, with no attachments
I think the original message you ware replying to was HTML with embedded images, perhaps a company logo. Embedded images are special attachments but they don't show in the attachments area.

I think this is another case of bug 532395. This is an area we've been addressing, this should be a lot better in recent beta versions or the new TB 52 being released in March 2017.
(Reporter)

Comment 2

a year ago
First - thank you for looking at this problem. :-)

Yes, it does look like that is the same problem I am having. This problem can now be closed.

I want to throw out there that just recently, Thunderbird will sometimes send a message and it says "Message Sent Successfully..." but the message dialog does not close. It just sits there and I have to get out of Thunderbird and back in to close the dialog box. This is under XP. Is this a known issue? If not I can post another bug report. Otherwise, I'll just wait for the fix.
For the second problem, the "Message Sent Successfully" not closing, please file another bug. It's not an issue I've seen.

Note that XP is not our best supported platform and intermittent problems ("sometimes") are not the developers' favourites. Is this behaviour new? Has something changed on your machine?
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 532395
(Reporter)

Comment 4

a year ago
The only updates I am getting are from FireFox, Thunderbird, and RevoUninstaller. At least, in the last month that was.....wait...Microsoft sent out an update for Office 2007 and their program that allows Office 2003 and earlier to read/write the new docx files. I do not think that affected Thunderbird.

(Ya know - people say Microsoft is no longer sending out updates to XP but I still get them about once every four months. Usually only if some severe virus has been found or some severe breach to the OS has been found. Also, it is usually just one or two KBs.)

Before I post this bug I want to catch Thunderbird doing it and I'll do a screen snapshot to show what is happening. :-)
You need to log in before you can comment on or make changes to this bug.