FindProxyForURL().type should be able to return new value "wpad"

RESOLVED DUPLICATE of bug 1443259

Status

P3
normal
RESOLVED DUPLICATE of bug 1443259
2 years ago
5 months ago

People

(Reporter: mattw, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [proxy] triaged)

(Reporter)

Description

2 years ago
The "WPAD" return type should work similarly to the auto_detect proxy mode in the Chrome API, which takes the proxy configuration from a PAC script that can be downloaded at http://wpad/wpad.dat.

For more information, see the proxy API design document: https://docs.google.com/document/d/1W45o5X2bFRPrTaQDFp9IzTJ8njCVfEgyENS7i2owaUI/edit?usp=sharing
How is this fixed/resolved? Is it already supported by the implementation in bug #1295807?
Flags: needinfo?(mwein)
(Reporter)

Comment 2

2 years ago
Please see https://bugzilla.mozilla.org/show_bug.cgi?id=1319630#c2.
Flags: needinfo?(mwein)
(Reporter)

Updated

2 years ago
webextensions: --- → ?
(Reporter)

Updated

2 years ago
webextensions: ? → ---
This should become a new return type as part of bug 1381290.
Priority: -- → P3
Summary: Add support for the new "WPAD" return type to FindProxyForURL → FindProxyForURL().type should be able to return new value "wpad"

Comment 4

a year ago
Mozilla, please fix this bug please as soon as possible, without foxy proxy and similar web-extensions use your browser completely impossible.

If you have already decided to use web-extensions, then make like on Chrome. Chrome does not have this problem.

Thanks.
Comment hidden (off-topic)
Given the new asyn api we will deprecate the non-complaint pac script initially done for webextensions.
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1443259

Updated

5 months ago
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.