Closed Bug 1443259 Opened 3 years ago Closed 11 months ago

Remove proxy.register/unregister

Categories

(WebExtensions :: Request Handling, enhancement, P2)

58 Branch
enhancement

Tracking

(firefox71 fixed)

RESOLVED FIXED
Future
Tracking Status
firefox71 --- fixed

People

(Reporter: mixedpuppy, Assigned: mixedpuppy)

References

(Blocks 1 open bug, )

Details

(Keywords: dev-doc-complete)

Attachments

(1 file)

The initial proxy api created a pseudo-pac script since the proxy filter system was synchronous at that stage.  It never implemented the PAC APIs (partly due to a requirement for synchronous DNS in them), so normal in-the-wild PAC scripts will not work with this.  Now that an asynchronous api has landed, we should deprecate the old stuff and get it removed eventually.
Duplicate of this bug: 1319630
Duplicate of this bug: 1319631
Duplicate of this bug: 1396485
Duplicate of this bug: 1319634
See Also: → 1456786
bug 1456786 is unrelated to the proxy api.
See Also: 1456786
FYI: bug 1456786 contains one note that is relevant to the proxy.register API:

> The only reason for subscribing to messages on the parent process manager is:
> - ProxyScriptContext
>   * context.messageManager = cpmm:
> https://searchfox.org/mozilla-central/rev/36dec78aecc40539ecc8d78e91612e38810f963c/toolkit/components/extensions/ProxyScriptContext.jsm#361
>   * Messenger:
> https://searchfox.org/mozilla-central/rev/36dec78aecc40539ecc8d78e91612e38810f963c/toolkit/components/extensions/ProxyScriptContext.jsm#508

If this old proxy API is removed, then the proxy script context disappears too, and then the main process does not have recipients for extension messages, except for native messaging and embedded WebExtensions (which are currently already handled separately).

This may change when the internals of extension messaging is refactored by Kris.
Ok, a comment for the see also would have been helpful.
See Also: → 1456786
FYI one option is to get this to work in its own thread.  Then we could actually implement the full PAC api, including synchronous dns.  In that case, we wouldn't deprecate this api.  Supporting multiple PAC scripts would be useful for organizations that rely on them.  I haven't really looked into it, not sure how much effort it is.
Product: Toolkit → WebExtensions
Priority: P3 → P2

This bug is preventing the operation with switching of proxy servers by extensions in Firefox.
Can someone pay attention to it.
Thanks.

(In reply to signfinder from comment #9)

This bug is preventing the operation with switching of proxy servers by extensions in Firefox.
Can someone pay attention to it.
Thanks.

How would this bug prevent you from doing that? This bug is about removing a feature, not about adding something new.

Blocks: 1545811

Changing to a more accurate title.

Target is Firefox 71.

Summary: deprecate proxy.register/unregister → Remove proxy.register/unregister
Target Milestone: --- → Future

Can you read my #3 comment in here please
https://bugzilla.mozilla.org/show_bug.cgi?id=1545811#c3
Not reposting it here.

Duplicate of this bug: 1388619
Blocks: 1566843

In addition to removing register/onregister/onProxyError from proxy docs: need to delete toProxyScript from https://developer.mozilla.org/en-US/docs/Mozilla/Add-ons/WebExtensions/API/runtime/sendMessage

Keywords: dev-doc-needed
Pushed by scaraveo@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d5ccb3bf4c1b
remove deprecated proxy APIs r=robwu
Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Assignee: nobody → mixedpuppy

Hello,

Will this require manual validation? If yes, please provide some steps to reproduce in order to correctly test it and also, please set the "qe-verify+" flag. Otherwise, could the "qe-verify-" flag be added? Thanks!

Flags: needinfo?(mixedpuppy)

This is code removal and the remaining APIs have tests and have existed for a long time now.

Flags: needinfo?(mixedpuppy) → qe-verify-

Looks like we've done the docs for this one; see https://github.com/mdn/sprints/issues/2278

You need to log in before you can comment on or make changes to this bug.