printing distorts images in table cell overlapping page break

RESOLVED WORKSFORME

Status

()

P2
normal
RESOLVED WORKSFORME
17 years ago
15 years ago

People

(Reporter: paul.gammans, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020315
BuildID:    20020315 AKA 0.9.9

If the cell of a table, containing an image, is split across a page break then
the image get distored, ie the image squashed into the both parts of the cell
before and after the page break.

I would expect this to cut the image into two or move the cell to the second page.

(testcast and resultant ps to follow)

Reproducible: Always
Steps to Reproduce:
1.Open testcase
2.Print
3.View results
(Reporter)

Comment 1

17 years ago
Created attachment 74949 [details]
Image 1 for test case
(Reporter)

Comment 2

17 years ago
Created attachment 74953 [details]
Test case (3x5 table of image 1)

Comment 3

17 years ago
 Unable to print the whole images in the last column. Confirmed on WIN2K 
2002031803 build. 
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

17 years ago
 Even when I scroll the scroll bar down and up the images do not dispaly 
correctly.

Comment 5

17 years ago
-->
Assignee: rods → karnaze
(Reporter)

Comment 6

17 years ago
comment #3 talks ablout images in last column, though these are cliped
and never printed i guess this is a seperate bug, i was refering to
distortion of images on about the 4 row of my printout.

Intresting to note the image is correctly split on the print prewiew.
I'll attach an printout example showing the fault.


Also i like to Confirmed that the error i'm trying to show is not
present on WIN32 Build ID 2002020406
(Reporter)

Comment 7

17 years ago
I'm having problems attaching the examples so hear as some links to them, if the
of any use could you attach them.

The PDF was created from the ps.

http://www.brunel.ac.uk/~dtpgprg/mozilla/image-distort.pdf  [87648]
http://www.brunel.ac.uk/~dtpgprg/mozilla/image-distort.ps.gz  [156006]

Updated

16 years ago
Blocks: 157675

Comment 8

16 years ago
WFM on Linux with mozilla 1.0 rc3

Comment 9

16 years ago
Bug confirmed for Mozilla 1.1 on Windows 2000 and Windows XP.
Works fine (images get split) for Mozilla 1.2a on Windows XP.

With papersize A4, the page break is in the 5th row, which
might explain comment #6.

Comment 10

16 years ago
I have found that this happens under Linux using png images any time that an
image is printed across a page boundry.

Comment 11

16 years ago
Rats!  I noticed this problem, searched though Bugzilla to find a
relevant bug report, realized my symptom was slightly different (no
table cell involved), thought I had useful information to contribute,
then got to smartin's report from two days ago.  So all I can says is
a useless "ditto": a PNG image which fell across a page boundary was
displayed twice, once squeezed to fit in the remaining space on page
one, then normally on page two.

I've added a vote to this bug.  Based purely on the symptoms, there
might be some connection with this other report I found in my search:
Bug# 125276 ("Printing causes squished images on second page;
replicates images on first page")

Updated

16 years ago
Priority: -- → P2
Target Milestone: --- → Future

Comment 12

16 years ago
Created attachment 106181 [details]
ps output (works)

Still works for me. see the output ps

Comment 13

16 years ago
These three bugs may be duplicates: bug 125276, bug 128923, bug 131970

Comment 14

16 years ago
mass reassign to default owner
Assignee: karnaze → table
Component: Printing → Layout: Tables
QA Contact: sujay → madhur
Target Milestone: Future → ---

Updated

16 years ago
Target Milestone: --- → Future

Comment 15

16 years ago
print bugs
Assignee: table → printing
Component: Layout: Tables → Printing
QA Contact: madhur → sujay
Target Milestone: Future → ---

Comment 16

15 years ago
Created attachment 130636 [details]
PDF showing compressed images

Is anyone working on this? This problem has been around
forever. I've attached a PDF showing the problem that
I'm seeing. 

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030728 Mozilla
Firebird/0.6.1

This PDF is generated from:

http://www.techonline.com/community/tech_group/eda/22966

The PDF only contains page 3 and 4 since the full document
is 303K and thus over the 300K limit for bugzilla attachments.

Comment 17

15 years ago
Probably a dupe of bug 119263.
Isn't this a dupe of Bug 130568 ?

Comment 19

15 years ago
Is this bug still an issue in the recent nightlies?

Comment 20

15 years ago
I can't reproduce this problem. With both the test case and the URL from comment
16, images split over two pages are not distorted. This was probably fixed by
the checkins for bug 80190 or bug 225243.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.