Closed Bug 125276 Opened 21 years ago Closed 18 years ago

Printing causes squished images on second page; replicates images on first page

Categories

(Core :: Printing: Output, defect, P2)

x86
Windows XP
defect

Tracking

()

RESOLVED FIXED
mozilla1.8alpha3

People

(Reporter: kjoshkelley, Assigned: bzbarsky)

References

()

Details

(Keywords: fixed-aviary1.0, fixed1.7.5)

Attachments

(3 files)

When printing out the site http://www.dreamtimebaby.com, the site will print 
however on the second page it will print out the left sidebar again only very 
small and squished togeather.
confirming...I also see this problem on win 98 using 3/20 build.

this is not a DUP.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Printing causes truncated sidebar on separate page → Printing causes squished images on second page; replicates images on first page
I have seen a similar problem like this, not sure if it is related. It looks
fine in Print Preview
Assignee: rods → dcone
Whiteboard: dupme?
Whiteboard: dupme? → dupeme?
Priority: -- → P1
Target Milestone: --- → mozilla1.3alpha
These three bugs may be duplicates: bug 125276, bug 128923, bug 131970
Target Milestone: mozilla1.3alpha → ---
-> jkeiser
Assignee: dcone → jkeiser
Priority: P1 → P2
Target Milestone: --- → Future
Dupe of bug 146799?
Hi, wading deeper through bugzilla, I found that
http://bugzilla.mozilla.org/show_bug.cgi?id=214654 (which is far newer than this
bug) seems to center on the same problem.  The test case that I gave (
http://mike.quacks.org/moztest.html ) probably touches on the same problems you
this bug originally highlighted, however the scaling 83% doesn't help at all in
my case.

I'm not a mozilla programmer, but I suspect that  mozilla for windows's
inability to keep to css definitions (like a div of a specific width & height)
to be indicative of a bigger problem than just a font change.
Woops, sorry to add to spam, I posted a comment that was intended for a
different bug ... ( http://bugzilla.mozilla.org/show_bug.cgi?id=213179 ) ..
terribly sorry.
Probably a dupe of bug 119263.
*** Bug 197441 has been marked as a duplicate of this bug. ***
Is this bug still an issue in the recent nightlies?
Summary
-------
The summary
  "Printing causes squished images on second page; replicates images on first 
page"
is wrong. Both printings of the image are squeezed/squished and it may happen 
in
the middle of a page far away from any page break. A new corrected summary
should be something like:
  "Image is printed twice in the space the image should occupy, both copies are
   squeezed/squished"

Problem description
-------------------
The initial problem description and comments of duplicate bug# 209452 was 
better
and more complete. A new corrected and expanded problem description should be
something like:

  A picture which doesn't fit fully on a page is printed wrong. Instead of
  cutting it or inserting a page break (probably the best option), Mozilla
  squeezes the picture so that it fits on the first page and creates a second
  squeezed copy of the same picture on the second page.

  Mozilla sometimes prints 2 squeezed copies of a picture in the middle of a
  page far away from any page break even when an unsqueezed copy of the picture
  would fit on the page.

  In both cases the sum of the heights of both squeezed copies of a picture
  seems roughly to be the height the picture should have as a single picture if
  it wasn't squeezed.

OS
--
The OS field is wrong. The symptoms of bug# 197441 and duplicate bug# 209452
have been observed on computers running:
- Microsoft Windows 2000
- Microsoft Windows XP Professional SP1 English
- Linux

Versions
--------
I have experienced the problem with a lot of web pages in Mozilla version 1.2.1
and 1.4.

Reproducible
------------
Always.

Examples
--------
Image at page break:
  http://www.tech-report.com/reviews/2003q3/abit-ic7-g/index.x?pg=2
    Image 1: Biggest on first page, a bit on the second
    Image 3: Biggest on first page, a tiny bit on the second
    Image 5: Approximately two equal

Image in the middle of a page far away from any page break:
  http://www.tomshardware.com/network/20030630/home_network-31.html
    - 2 approximately equal sized parts (55% 45%?)
  http://www.tomshardware.com/network/20030630/home_network-32.html
    - Split approximately 80% 20%
  Both are reproducible every time.

System information
------------------
Mozilla 1.4 Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) 
Gecko/20030624
Microsoft Windows XP SP1 English
Printers:
  HP LaserJet 9000 dn, PCL driver
  HP Color LaserJet 4500, PCL driver
Ole-Henrik, Mozilla 1.2.1 and 1.4 are really old, and this might have been fixed
some time ago. Could you re-test with a current nightly build (like, from today
or yesterday)?
I have retested my examples with a new version as requested by Oliver Klee.

Version
-------
The problem is still there in a nightly build downloaded on 06 January 2004 
12.06 CET:
   Mozilla 1.7a
   Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a) Gecko/20040105

Examples
--------
Image at page break:
  http://www.tech-report.com/reviews/2003q3/abit-ic7-g/index.x?pg=2
    The problem is still there but it affects different images.
    Maybe some surrounding information on the page has been changed?
    Image 1: OK
    Image 2: A bit on the first page, biggest on the second
    Image 3: OK
    Image 4: Approximately two equal
    Image 5: OK
    Image 6: Approximately two equal
    Image 7: OK

Image in the middle of a page far away from any page break:
  The problem is still there and fits the old description.
  http://www.tomshardware.com/network/20030630/home_network-31.html
    - 2 approximately equal sized parts (55% 45%?)
  http://www.tomshardware.com/network/20030630/home_network-32.html
    - Split approximately 80% 20%

System information
------------------
Mozilla 1.7a Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a) 
Gecko/20040105
Nightly build downloaded on 06 January 2004 12.06 CET

Microsoft Windows XP SP1 English, dayly run of Windows Update
Printers:
  HP LaserJet 9000 dn, PCL driver, A4 paper
*** Bug 151678 has been marked as a duplicate of this bug. ***
Also happens for me on Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.4)
Gecko/2003070 .
So it seems to be pretty cross-platform.
I have retested with the Mozilla 1.7 Beta:
   Mozilla 1.7b
   Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040316

The problem is still there.
The problem still occurs in Mozilla 1.7 and in Firefox 0.8 on (at least)
Windows and Linux, seemingly regardless of what printer driver is used.  The
attached PDF shows an example from Firefox on Windows 2000.
*** Bug 223834 has been marked as a duplicate of this bug. ***
*** Bug 248268 has been marked as a duplicate of this bug. ***
*** Bug 249243 has been marked as a duplicate of this bug. ***
On Firefox 0.9.1 (Windows XP SP1) I have the same problem, but instead of
squeezed images it happens with tables, in a page the table is printed squeezed
and in the next page printed again, usually even more squeezed.
You can test with pages from here: http://www.aulafacil.org/Ruso/CursoRuso.htm ,
it happens in most of them, for example
http://www.aulafacil.org/Ruso/Lecc-21-ruso.htm where the last table
(VOCABULARIO) is printed on page 1 and 2 squeezed on both.
It seems to depends on the printing margins of the page and printer. With an
Epson 1520 and Brother 5150D, tables print duplicated and squeezed only if for
that printer, the page margin would cut the table being printed. So sometimes it
happens with a printer, other times with the other, and most of the time with both.
setting blocking-aviary1.0RC1 ?
i think this is a major feature thats broken and it should be fixed ASAP.
Flags: blocking-aviary1.0RC1?
Sorry if anyone considers this spam, but IMO this is a serious bug (as it
effects the printing of virtually any page with images in it).

IMO this should have a higher severity and be made a major priority for fixing
by Firefox 1.0.  It still exists in Firefox 0.9.2 and I remember it existed in
Phoenix 0.2.

As has been stated before *both* "half"-images are squished so the summary is
not strictly true.

IMO the correct behaviour when an image crosses a page boundary is to shift it
onto the second page along with any related objects or text (e.g.: the next cell
in the row if the image is in a table) unless the image crosses two page
boundaries (in which case it should be made smaller or cut into bits).  Maybe
there needs to be some kind of system for reducing the size of images (or
printing just the page with the image on as landscape) for when this bug cannot
be fixed anther way and for the the other common prblem if images going off the
right-hand margin (which is I think bug 84223).

WRT comment #22: The "tables" on that site are actually images not tables (I
assume so that the Cyrillic characters display on systems that do not have
Cyrillic fonts).
Flags: blocking-aviary1.0RC1? → blocking-aviary1.0RC1-
Flags: blocking-aviary1.0?
*** Bug 254328 has been marked as a duplicate of this bug. ***
*** Bug 254435 has been marked as a duplicate of this bug. ***
Blocks: 234095
Attached patch Possible patchSplinter Review
Callek, could you test that patch on trunk for me, please?  And attach the
aviary diff you ended up with?
Comment on attachment 155405 [details] [diff] [review]
Possible patch

The basic idea is that in the one case of PrintDDB we didn't pass the source
rect along.  So we'd shoehorn the whole image into each of the parts of the
split.

This (or rather this modified slightly to apply to aviary) was tested and is
claimed to fix the bug...
Attachment #155405 - Flags: superreview?(tor)
Attachment #155405 - Flags: review?(ere)
bz's posted patch works, and the patch works on aviary, I'll create a diff and
attach tommorrow (really tired right now)
Same as Bz's patch with minor changes for aviary.
Comment on attachment 155660 [details] [diff] [review]
Same Patch for Aviary

Once this is reviewed, need to request approval aviary
Attachment #155660 - Flags: superreview?(tor)
Attachment #155660 - Flags: review?(ere)
Blocks: 168275
Comment on attachment 155405 [details] [diff] [review]
Possible patch

r+sr=roc
Attachment #155405 - Flags: superreview?(tor)
Attachment #155405 - Flags: superreview+
Attachment #155405 - Flags: review?(ere)
Attachment #155405 - Flags: review+
No longer blocks: 234095
*** Bug 234095 has been marked as a duplicate of this bug. ***
Assignee: john → bzbarsky
Whiteboard: dupeme?
Target Milestone: Future → mozilla1.8alpha3
Fixed for 1.8a3.
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → FIXED
Blocks: 164421
Roc, willing to do a quick tap of "r/sr+" on the second patch for aviary, same
except |nsIDrawingSurface*|  is |nsDrawingSurface|

that so we can ask for approval aviary, and get it in before Pre-Release
Comment on attachment 155660 [details] [diff] [review]
Same Patch for Aviary

If you get Aviary approval, please check in on the 1.7 branch also.
Attachment #155660 - Flags: superreview?(tor)
Attachment #155660 - Flags: superreview+
Attachment #155660 - Flags: review?(ere)
Attachment #155660 - Flags: review+
Attachment #155660 - Flags: approval1.7.3+
Comment on attachment 155660 [details] [diff] [review]
Same Patch for Aviary

This is worth taking; simple, safe patch for an annoying problem.
Attachment #155660 - Flags: approval-aviary?
Comment on attachment 155660 [details] [diff] [review]
Same Patch for Aviary

a=asa for aviary checkin.
Attachment #155660 - Flags: approval-aviary? → approval-aviary+
Fixed on branches.
Flags: blocking-aviary1.0?
Blocks: 257551
*** Bug 257724 has been marked as a duplicate of this bug. ***
*** Bug 264507 has been marked as a duplicate of this bug. ***
No longer blocks: 164421
Blocks: 158464
*** Bug 257551 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.