Move Linux64 mochitest-browser-chrome to Ubuntu 16.04

RESOLVED FIXED in Firefox 55

Status

RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: RyanVM, Assigned: kshriram18)

Tracking

(Depends on: 1 bug)

unspecified
mozilla55
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox55 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Same LSAN leaks as other suites, albeit intermittent.

Beyond that, bug 1273887 and bug 1123438 hit at a very high frequency on opt:
https://treeherder.mozilla.org/logviewer.html#?job_id=31673601&repo=try
https://treeherder.mozilla.org/logviewer.html#?job_id=31673275&repo=try

On debug, various webext tests are basically permafail.
https://treeherder.mozilla.org/logviewer.html#?job_id=31674227&repo=try
https://treeherder.mozilla.org/logviewer.html#?job_id=31674035&repo=try

Also on debug, bug 1285701 is permafailing:
https://treeherder.mozilla.org/logviewer.html#?job_id=31674042&repo=try

And a frequent e10s-only toolkit/modules/tests/browser leak:
https://treeherder.mozilla.org/logviewer.html#?job_id=31674024&repo=try

Lots of other random timeouts on debug, hard to say how much 16.04 is at fault specifically, though. The one in browser/base/content/test/tabcrashed/browser_shown.js seems particularly prevalent, though. Also, the sessionstore tests are quite timeout-prone too.

Finally, bug 1306666 is permafailing on debug.
https://treeherder.mozilla.org/logviewer.html#?job_id=31674511&repo=try
https://treeherder.mozilla.org/logviewer.html#?job_id=31674500&repo=try
Blocks: 1319650
(In reply to Ryan VanderMeulen [:RyanVM] from comment #0)
> And a frequent e10s-only toolkit/modules/tests/browser leak:
> https://treeherder.mozilla.org/logviewer.html#?job_id=31674024&repo=try

FWIW this leak is no longer reproducing.
toolkit/modules/tests/browser runs under bc2/7 in this push:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=5c4e0a04b80ce9c0aad3c1594370ecfb915f4abf&selectedJob=32386016
Depends on: 1323616
(Assignee)

Comment 3

2 years ago
(In reply to Shriram (irc: Mavericks) from comment #2)
> Latest try run at
> https://treeherder.mozilla.org/#/
> jobs?repo=try&revision=c4fb0bf102f76c3458b477cabc63a8820960e4f4

with e10s at https://treeherder.mozilla.org/#/jobs?repo=try&revision=cbfc1304012c5d1e1b3aeced6d62f33cbcbf8471
(Assignee)

Comment 4

2 years ago
Ignore the try run in the last comment.
Latest one including e10s's https://treeherder.mozilla.org/#/jobs?repo=try&revision=6f3765f5da7ae1bdd66341e3077dbe7069f6fb04
Depends on: 1348097
(Assignee)

Comment 5

2 years ago
Created attachment 8862827 [details]
Patch to have linux64 mochitest-browser-chrome tests run on 16.04
Assignee: nobody → kshriram18
Attachment #8862827 - Flags: review?(jmaher)
Attachment #8862827 - Flags: review?(jmaher) → review+

Comment 6

2 years ago
Pushed by jmaher@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/2282846d3ef2
Move mochitest-browser-chrome tests to run on 16.04. r=jmaher
https://hg.mozilla.org/mozilla-central/rev/2282846d3ef2
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox55: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
Duplicate of this bug: 1323616
You need to log in before you can comment on or make changes to this bug.