Enabling "Always use private browsing mode" crash Nightly after choosing other panel from preferences

RESOLVED DUPLICATE of bug 1320112

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 1320112
2 years ago
2 years ago

People

(Reporter: Marko Andrejić, Unassigned)

Tracking

53 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(firefox53 affected)

Details

(Reporter)

Description

2 years ago
OS: BackBox (based on Ubuntu) 64-bit - running on virtual machine
Build ID: 20161124030208

Steps to reproduce:

1. Open preferences and switch to Privacy panel
3. Change History to Use custom settings for history
4. Enable Always use private browsing mode (you must restart Nightly)
5. Open preferences and try to switch to any other panel

Actual result:

Nighly crash with pop-up crash report window.

Expected result:

Nighlty should switch to selected tab.


Note: Same thing happens if you change History to Never remember history and restart Nighlty. The only solution I found to open again any other panel is to refresh Nightly.

Comment 1

2 years ago
Can you link to a crashreport from about:crashes? Is this with an official mozilla.org build or a distro-provided thing or...?
Component: General → Untriaged
Flags: needinfo?(marko.andrejic93)
(Reporter)

Comment 2

2 years ago
Crashreport link: https://crash-stats.mozilla.com/report/index/3063940f-d23a-44bf-a5cb-8f1352161124

It is official build, downloaded from Nighlty page.


Note: My bug might be duplicate of this bug https://bugzilla.mozilla.org/show_bug.cgi?id=1320112 the differences are steps to reproduce, the way we get crash.
Flags: needinfo?(marko.andrejic93)

Comment 3

2 years ago
Yes, this is a dupe. Thanks for noticing!
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1320112
You need to log in before you can comment on or make changes to this bug.