Incoming message with domainpart-only JID are dropped

RESOLVED DUPLICATE of bug 1246431

Status

Chat Core
XMPP
RESOLVED DUPLICATE of bug 1246431
a year ago
a year ago

People

(Reporter: mcgee, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/51.0.2704.79 Safari/537.36 Edge/14.14393

Steps to reproduce:

A private XMPP Server is configured to broadcast global notifications from its own JID (domainpart-only, no nodepart).  When externally triggered, the server will send a message to my connected client from "pleaseignore.com" (i.e. no node).

(NOTE: The server in question is not public nor do I have any level of administrative access to it.)


Actual results:

Thunderbird 45.5.0 simply drops the message and logs an error:

Timestamp: 11/26/2016 13:02:57
Error: Could not create conversation as jid is broken: pleaseignore.com
Source File: resource:///modules/xmpp.jsm
Line: 2105
Source Code:
prpl-jabber: XMPPAccountPrototype.createConversation


Expected results:

The content of the message should have been made available to me in some form.  Most clients (e.g. Pidgin, Trillian, etc.) will open a conversation with the JID.

Comment 1

a year ago
Thanks for the bug report! This is already fixed in Thunderbird 47 and above.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Component: Instant Messaging → XMPP
Product: Thunderbird → Chat Core
Resolution: --- → DUPLICATE
Version: 45 Branch → 45
Duplicate of bug: 1246431
You need to log in before you can comment on or make changes to this bug.