Crash in java.lang.IllegalArgumentException: SharedPreferences:Set was not registered at org.mozilla.gecko.EventDispatcher.unregisterListener(EventDispatcher.java)

RESOLVED FIXED in Firefox 53

Status

()

Firefox for Android
General
--
critical
RESOLVED FIXED
2 years ago
a year ago

People

(Reporter: njn, Assigned: jchen)

Tracking

({crash})

unspecified
Firefox 53
Unspecified
Android
crash
Points:
---

Firefox Tracking Flags

(firefox51 unaffected, firefox52 unaffected, firefox53 fixed)

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
This bug was filed from the Socorro interface and is 
report bp-7e3c39d0-4bcd-4b3d-ae0e-904082161126.
=============================================================

New crash, first appeared in Nightly 20161118030222, AFAICT.

snorp, any ideas?
Flags: needinfo?(snorp)
EventDispatcher regression?
Flags: needinfo?(nchen)
Looks like it
Flags: needinfo?(snorp)
(Assignee)

Updated

2 years ago
Assignee: nobody → nchen
Status: NEW → ASSIGNED
Flags: needinfo?(nchen)
(Assignee)

Comment 3

2 years ago
Created attachment 8815333 [details] [diff] [review]
Revert to global EventDispatcher for certain events (v1)

These events are not accessed through GeckoApp, and should therefore use
the global EventDispatcher rather than the per-GeckoApp/GeckoView
EventDispatcher. Otherwise, we could run into situations where we end up
registering / unregistering the same event using different
EventDispatcher instances, causing exceptions like this one.
Attachment #8815333 - Flags: review?(s.kaspari)
Attachment #8815333 - Flags: review?(s.kaspari) → review+

Comment 4

2 years ago
Pushed by nchen@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/e7ae0014cb1e
Revert to global EventDispatcher for certain events; r=sebastian

Comment 5

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/e7ae0014cb1e
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox53: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 53
Duplicate of this bug: 1318747
status-firefox51: --- → unaffected
status-firefox52: --- → unaffected
You need to log in before you can comment on or make changes to this bug.