Closed Bug 1320832 Opened 4 years ago Closed 4 years ago

Default mail.imap.filter_on_new to true

Categories

(MailNews Core :: Filters, enhancement)

enhancement
Not set
normal

Tracking

(thunderbird52+ fixed, thunderbird53 fixed)

RESOLVED FIXED
Thunderbird 53.0
Tracking Status
thunderbird52 + fixed
thunderbird53 --- fixed

People

(Reporter: rkent, Assigned: rkent)

References

(Depends on 2 open bugs)

Details

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #308148 +++

Bug 308148 added mail.imap.filter_on_new and set it to false. There have been no reported problems with testers of this (with the value true) but we need to widen the scope of testing. Setting the value to true will ensure that imap messages are filtered when they are new to a Thunderbird installation (based on highwater) rather than NOT filtering if messages are read.
Attached patch set to trueSplinter Review
Assignee: nobody → rkent
Status: NEW → ASSIGNED
Attachment #8815115 - Flags: review?(acelists)
I will give my anecdote: This has worked for me for nine months, with zero problems. I regularly check messages on my phone, and when I open my laptop back up, everything gets sorted just right. Enabling that preference simplified my workflow enormously.

There are rare times when Thunderbird will simply stop filtering entirely, until closed and reopened, but that has nothing to do with read status.
Comment on attachment 8815115 [details] [diff] [review]
set to true

Review of attachment 8815115 [details] [diff] [review]:
-----------------------------------------------------------------

Really hard review ;-)
r=jorgk if you want or wait for Aceman.
Attachment #8815115 - Flags: review+
Absolutely loving this feature. Life-saving one. It's been working correctly since day one. I use TB to sort my mail to folders (because of another bug in other-folders-checking if server-side sorting was used) and now I can read my mail on my phone or tablet and TB would correctly dispatch messages through filters when it checks the accounts afterwards.
TB has another bug where tray notification icon persists if I first read new messages on my phone After TB has received them already (and subsequently when TB checked the account, the icon doesn't disappear) but that's another story.
Comment on attachment 8815115 [details] [diff] [review]
set to true

Review of attachment 8815115 [details] [diff] [review]:
-----------------------------------------------------------------

So this causes filters to run on all new (yet unseen) messages whether they are read or not?
Maybe useful in these days of poking one's mailbox via webmail first.
Attachment #8815115 - Flags: review?(acelists) → review+
https://hg.mozilla.org/comm-central/rev/246f134d028e
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 53.0
Comment on attachment 8815115 [details] [diff] [review]
set to true

[Approval Request Comment]
We'll want this in TB52 as it matches user expectations that Thunderbird always filters new messages. Particularly important when you check messages on a mobile phone.
Attachment #8815115 - Flags: approval-comm-aurora?
Attachment #8815115 - Flags: approval-comm-aurora? → approval-comm-aurora+
Depends on: 1334943
Duplicate of this bug: 970809
Depends on: 1368056
You need to log in before you can comment on or make changes to this bug.