Closed Bug 1320891 Opened 3 years ago Closed 3 years ago

Make some webrtc tests build with gcc 7.0 and --enable-warnings-as-errors

Categories

(Core :: WebRTC, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla53
Tracking Status
firefox53 --- fixed

People

(Reporter: Sylvestre, Assigned: Sylvestre)

References

Details

Attachments

(1 file)

First, in media/webrtc/signaling/test/mediaconduit_unittests.cpp, gcc 7.0 is complaining about the following:
 error: suggest explicit braces to avoid ambiguous 'else' [-Werror=dangling-else]
I guess this is caused by the ASSERT_NE define. As it doesn't hurt, we can add {} to silent it.

Second, similar to bug 1320878, an expression in an assert is always returning true.
Comment on attachment 8815203 [details]
Bug 1320891 - Make some webrtc tests build with gcc 7.0 and --enable-warnings-as-errors

https://reviewboard.mozilla.org/r/96232/#review96468
Attachment #8815203 - Flags: review?(docfaraday) → review+
Pushed by sledru@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/918309d4aea0
Make some webrtc tests build with gcc 7.0 and --enable-warnings-as-errors r=bwc
Assignee: nobody → sledru
https://hg.mozilla.org/mozilla-central/rev/918309d4aea0
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
You need to log in before you can comment on or make changes to this bug.