my cannon pixma printer will no longer print in grayscale, it will with safari, this is not a printer problem

RESOLVED DUPLICATE of bug 1303051

Status

()

Core
Printing: Setup
RESOLVED DUPLICATE of bug 1303051
a year ago
a year ago

People

(Reporter: u584303, Unassigned)

Tracking

50 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20161123182536

Steps to reproduce:

tried to pint color coupon on web in grayscale but it came out in color. I was always able to print in grayscale , this problem just started a few weeks ago. When I print using safari as a browser I am able to print in greyscale. Calle cannon support it is not a printer problem. I have a canon pixma MG5220 usb connected to a mac


Actual results:

Printed in color


Expected results:

print should have been grayscale
(Reporter)

Updated

a year ago
Summary: my cannon pixma printer will no longer print in grayscale it will with safari not a printer issue → my cannon pixma printer will no longer print in grayscale, it will with safari, this is not a printer problem

Comment 1

a year ago
Could you test with a fresh profile, please.
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
Component: Untriaged → Printing: Setup
Product: Firefox → Core
Thanks for taking the time to report this.

Haik - could this be fixed by one of your recent patches on Nightly or is this some other setting that isn't getting passed down to the child (assuming that this is an e10s problem)?
Flags: needinfo?(haftandilian)
With the Epson printer I tested, this appears to be fixed on Developer Edition 52.0a2 (2016-11-30) and Nightly at this time on OS X 10.12. (Some printing fixes were uplifted to Dev Edition in the last few days so the version matters.)

In my case, the print dialog has "Black and White" enabled by default. I tested 47, 50, 51 and all of those releases don't appear to respect the black and white setting.

Leaving the needinfo for myself to root cause the problem.
Flags: needinfo?(haftandilian)
Flags: needinfo?(haftandilian)
Duplicate of this bug: 1324458
After looking through the code, yes it makes sense that this problem is fixed by bug 1303051. In build 51, after displaying the print dialog, there are no calls enable/disable color printing by setting nsPrintSettings::SetPrintInColor(). The field nsPrintSettings.mPrintInColor is set to true by default so we would always print in color.
Flags: needinfo?(haftandilian)
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1303051
You need to log in before you can comment on or make changes to this bug.