Closed Bug 1322701 Opened 3 years ago Closed 3 years ago

Title bar toggling button in customize mode on OS X misses image

Categories

(Firefox :: Theme, defect)

52 Branch
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 53
Tracking Status
firefox50 --- unaffected
firefox51 --- unaffected
firefox52 + verified
firefox53 --- verified

People

(Reporter: Gijs, Assigned: Gijs)

References

Details

(Keywords: regression)

Attachments

(1 file)

No description provided.
CAN_DRAW_IN_TITLEBAR isn't defined in the OS X theme dir so the images never get shown.
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
tracking for 52 as new regression
Comment on attachment 8817719 [details] [diff] [review]
define CAN_DRAW_IN_TITLEBAR in the theme moz.build files,

Can you do this in browser/themes/moz.build similar to how we define it elsewhere?

Or maybe we can do this in browser/moz.build even? Not sure how exactly this stuff propagates.
Attachment #8817719 - Flags: review?(dao+bmo)
(In reply to Dão Gottwald [:dao] from comment #4)
> Comment on attachment 8817719 [details] [diff] [review]
> define CAN_DRAW_IN_TITLEBAR in the theme moz.build files,
> 
> Can you do this in browser/themes/moz.build similar to how we define it
> elsewhere?
> 
> Or maybe we can do this in browser/moz.build even? Not sure how exactly this
> stuff propagates.

I tried doing this in browser/themes with a copy-paste of what we do in browser/base, and that didn't seem to work. :-\
Flags: needinfo?(dao+bmo)
Comment on attachment 8817719 [details] [diff] [review]
define CAN_DRAW_IN_TITLEBAR in the theme moz.build files,

Okay, let's do it like this for now since we want to uplift, although we should still look into consolidating this. Maybe a build system peer can help.
Flags: needinfo?(dao+bmo)
Attachment #8817719 - Flags: review+
Has Regression Range: --- → yes
Keywords: checkin-needed
Comment on attachment 8817719 [details] [diff] [review]
define CAN_DRAW_IN_TITLEBAR in the theme moz.build files,

Approval Request Comment
[Feature/Bug causing the regression]: bug 1302759
[User impact if declined]: titlebar toggling button misses an image
[Is this code covered by automated tests?]: no, styling-only change
[Has the fix been verified in Nightly?]: no
[Needs manual test from QE? If yes, steps to reproduce]: yes, open customize mode on OS X and Windows and check the titlebar toggle button on the bottom left has an image
[List of other uplifts needed for the feature/fix]: none
[Is the change risky?]: no
[Why is the change risky/not risky?]: trivial change to restore pre-bug-1302759 state of existing CSS by modifying a build define
[String changes made/needed]: nope
Attachment #8817719 - Flags: approval-mozilla-aurora?
Pushed by cbook@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/600a0d1afdf0
define CAN_DRAW_IN_TITLEBAR in the theme moz.build files, r=dao
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/600a0d1afdf0
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 53
Can somebody from QE verify this fix in nightly?  See the steps in comment 7.
Flags: qe-verify+
Flags: needinfo?(andrei.vaida)
This is Verified Fixed in Nightly 53.0a1 (id: 20161215030215) on MacOs 10.12 Sierra.
See Also: → 1323741
Comment on attachment 8817719 [details] [diff] [review]
define CAN_DRAW_IN_TITLEBAR in the theme moz.build files,

theming fix for windows/osx, take in aurora52
Flags: needinfo?(andrei.vaida)
Attachment #8817719 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Version: unspecified → 52 Branch
I have reproduced this issue using Firefox  53.0a1 (20161209030212) on Mac OS X 10.9.5.
I can confirm this issue is fixed, I verified using Firefox 52.0b1 on Mac OS X 10.9.5.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.