Closed Bug 1322707 Opened 3 years ago Closed 3 years ago

Stop building signaling_unittest and mediapipeline_unittests

Categories

(Core :: WebRTC: Signaling, defect, P1)

defect

Tracking

()

RESOLVED FIXED
mozilla53
Tracking Status
firefox53 --- fixed

People

(Reporter: dminor, Assigned: dminor)

References

Details

Attachments

(1 file)

Rather than continue to block Bug 1316611 we should stop building these tests while we port them over.
Rank: 17
Assignee: nobody → dminor
Status: NEW → ASSIGNED
Comment on attachment 8817671 [details]
Bug 1322707 - Stop building signaling_unittest and mediapipeline_unittests;

https://reviewboard.mozilla.org/r/97894/#review98226
Attachment #8817671 - Flags: review?(rjesup) → review+
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1306329
There is a chicken-and-egg problem in bug 1306329, because it depends on bug 1306327, which actually breaks the build unless this is fixed, so that can't be done in bug 1306329.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Comment on attachment 8817671 [details]
Bug 1322707 - Stop building signaling_unittest and mediapipeline_unittests;

https://reviewboard.mozilla.org/r/97894/#review99042

Note this needs a rebase.
Attachment #8817671 - Flags: review?(mh+mozilla) → review+
(In reply to Mike Hommey [:glandium] from comment #4)
> There is a chicken-and-egg problem in bug 1306329, because it depends on bug
> 1306327, which actually breaks the build unless this is fixed, so that can't
> be done in bug 1306329.

This is actually not true ; it's another webrtc test that breaks ; but it's still better to keep this separate. (the patch here is also more complete)
Depends on: 1306329
(In reply to Mike Hommey [:glandium] from comment #6)
> (In reply to Mike Hommey [:glandium] from comment #4)
> > There is a chicken-and-egg problem in bug 1306329, because it depends on bug
> > 1306327, which actually breaks the build unless this is fixed, so that can't
> > be done in bug 1306329.
> 
> This is actually not true ; it's another webrtc test that breaks ; but it's
> still better to keep this separate. (the patch here is also more complete)

Agreed, I should have cancelled review on Bug 1306329 rather than close this.
Pushed by dminor@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/3460a22b7c62
Stop building signaling_unittest and mediapipeline_unittests; r=jesup,glandium
https://hg.mozilla.org/mozilla-central/rev/3460a22b7c62
Status: REOPENED → RESOLVED
Closed: 3 years ago3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
You need to log in before you can comment on or make changes to this bug.