Addon doorhanger icon is black instead of grey

VERIFIED FIXED in Firefox 52

Status

()

defect
P2
normal
VERIFIED FIXED
3 years ago
2 years ago

People

(Reporter: johannh, Assigned: dao)

Tracking

({polish, regression})

Trunk
Firefox 53
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox50 unaffected, firefox51 unaffected, firefox52+ verified, firefox53 verified)

Details

(Whiteboard: [fxprivacy] )

Attachments

(4 attachments)

Reporter

Description

3 years ago
See screenshots. This should be fixed and uplifted to Aurora. I know there's some relationship to bug 1304343 but the attached patch doesn't look like it fixes the issue. Dao, do you know more about that?
Flags: qe-verify+
Flags: needinfo?(dao+bmo)
Reporter

Comment 1

3 years ago
Posted image release
Reporter

Comment 2

3 years ago
Posted image aurora
Last good revision: c0ca8b0d966ee28bc6542a762f8a592cf76054d8
First bad revision: a481cba452933d5e7571fce7733b1ad7d41f493b

Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=c0ca8b0d966ee28bc6542a762f8a592cf76054d8&tochange=a481cba452933d5e7571fce7733b1ad7d41f493b
Keywords: polish
Priority: -- → P2
Whiteboard: [fxprivacy] [triage] → [fxprivacy]

Comment 4

3 years ago
[Tracking Requested - why for this release]:
Recent regression in primary UI appearance.
tracking for 52 as new regression
Assignee

Updated

3 years ago
Assignee: nobody → dao+bmo
Assignee

Updated

3 years ago
No longer depends on: 1304343
Assignee

Updated

3 years ago
Blocks: 1304708
Comment hidden (mozreview-request)
Assignee

Updated

3 years ago
Flags: needinfo?(dao+bmo)
Reporter

Comment 7

3 years ago
mozreview-review
Comment on attachment 8826143 [details]
Bug 1322922 - Use icon-colors.inc.svg in addon-install-anchor.svg.

https://reviewboard.mozilla.org/r/104164/#review104924

Looks good, thanks!
Attachment #8826143 - Flags: review?(jhofmann) → review+

Comment 8

3 years ago
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/32bc131f9812
Use icon-colors.inc.svg in addon-install-anchor.svg. r=johannh
Assignee

Comment 9

3 years ago
Comment on attachment 8826143 [details]
Bug 1322922 - Use icon-colors.inc.svg in addon-install-anchor.svg.

Approval Request Comment
[Feature/Bug causing the regression]: bug 1304708
[User impact if declined]: see attachment 8817910 [details]
[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: not yet
[Needs manual test from QE? If yes, steps to reproduce]: can be reproduced by installing an add-on from AMO
[List of other uplifts needed for the feature/fix]: /
[Is the change risky?]: no
[Why is the change risky/not risky?]: straightforward update to an SVG file that I missed in bug 1304708
[String changes made/needed]: /
Attachment #8826143 - Flags: approval-mozilla-aurora?

Comment 10

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/32bc131f9812
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 53
Comment on attachment 8826143 [details]
Bug 1322922 - Use icon-colors.inc.svg in addon-install-anchor.svg.

fix addon doorhanger appearance in aurora52
Attachment #8826143 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Iteration: --- → 53.5 - Jan 23
QA Contact: paul.silaghi
Reproduced the initial issue on Aurora 52.0a2 (Build ID: 20161211004007).

I can confirm that the Addon doorhanger icon is grey when using the latest Aurora 53.0a2 (Build ID: 20170131004003) On Windows 10 x64, Ubuntu 16.04 x64 and Mac OS X 10.11. 

But, I found a situation when the add-on doorhanger icon is not displayed at all when the add-on that is installed it's saved locally. Is this expected in any way? Please see the screenshot for more details.

Also, please note that the initial issue is reproducible also on the latest Firefox 51.0.1 (Build ID: 20170125094131)
Flags: needinfo?(dao+bmo)
Reporter

Comment 15

2 years ago
This is another side effect of bug 1300755.
Flags: needinfo?(dao+bmo)

Comment 16

2 years ago
Ah, thanks for flagging this Johann. I'll make sure to include the invalid pageproxystate caused by drag and drop or new tabs with "file:" URLs at least in manual testing for bug 1328304.

Comment 17

2 years ago
And I forgot to say thanks to Simona for finding the bug, although I wanted to :-)
Reporter

Comment 18

2 years ago
Yes, thank you, that was a good find!
Paolo, will the issue mentioned in Comment 14 going to be fixed in Bug 1328304 (can I add a comment with the scenario on it)? Or should I file a new bug for that?
Flags: needinfo?(paolo.mozmail)

Comment 20

2 years ago
To clarify, it's quite likely that this will continue to be the expected behavior even after bug 1328304 is fixed, so there is no need to file a bug. I'll have to make sure to test this scenario at least manually though.
Flags: needinfo?(paolo.mozmail)

Comment 21

2 years ago
[bugday-20170201]
Thank you Paolo for clarifying things for me. 

Based on Comment 14 and on Comment 20, setting the tracking flag for status-firefox53:	to verified.
Flags: qe-verify+
QA Contact: paul.silaghi
You need to log in before you can comment on or make changes to this bug.