Closed Bug 1323088 Opened 3 years ago Closed 3 years ago

Firefox Nightly 53.0a1 (2016-12-11) crashes in [@ @0x0 | mozilla::gfx::VRControllerManagerOpenVR ... ] & [@ @0x0 | mozilla::gfx::VRManager ... ]

Categories

(Core :: Graphics, defect, critical)

53 Branch
defect
Not set
critical

Tracking

()

VERIFIED FIXED
mozilla53
Tracking Status
firefox-esr45 --- unaffected
firefox50 --- unaffected
firefox51 --- unaffected
firefox52 --- unaffected
firefox53 + verified

People

(Reporter: Virtual, Assigned: daoshengmu)

References

Details

(Keywords: crash, nightly-community, regression)

Crash Data

Attachments

(1 file)

Crash Signature: [@ @0x0 | mozilla::gfx::VRControllerManagerOpenVR::Init ]
Assignee: nobody → dmu
Flags: needinfo?(dmu)
This bug is because we check LoadOpenVRRuntime() at VRDisplayManagerOpenVR::Create(). We have to make sure the runtime is loaded successfully, then creating the controller manager.
Adding some signatures, there are Mac crashes as well.
Crash Signature: [@ @0x0 | mozilla::gfx::VRControllerManagerOpenVR::Init ] → [@ @0x0 | mozilla::gfx::VRControllerManagerOpenVR::Init ] [@ @0x0 | mozilla::gfx::VRManager::Init] [@ @0x0 | mozilla::gfx::VRManager::AddVRManagerParent]
OS: Windows → All
Hardware: x86_64 → All
Tracking 53+ as this is a new regression that is now the #2 top crash on nightly in the last few days.
Comment on attachment 8818176 [details]
Bug 1323088 - OpenVR controller manager should not be created while loading runtime fail;

https://reviewboard.mozilla.org/r/98298/#review98714

Looks good, thanks!
Attachment #8818176 - Flags: review?(kgilbert) → review+
Keywords: checkin-needed
(In reply to Marcia Knous [:marcia - use ni] from comment #4)
> Tracking 53+ as this is a new regression that is now the #2 top crash on
> nightly in the last few days.

Sorry about this. I believe this patch will resolve it. Let's land it ASAP.
Pushed by cbook@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2dea832c2464
OpenVR controller manager should not be created while loading runtime fail; r=kip
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/2dea832c2464
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
Has Regression Range: --- → yes
Has STR: --- → irrelevant
Summary: Firefox Nightly 53.0a1 (2016-12-11) crashes in [@ @0x0 | mozilla::gfx::VRControllerManagerOpenVR::Init ] → Firefox Nightly 53.0a1 (2016-12-11) crashes in [@ @0x0 | mozilla::gfx::VRControllerManagerOpenVR ... ] & [@ @0x0 | mozilla::gfx::VRManager ... ]
No crashes since Firefox Nightly 53.0a1 (2016-12-15) build,
so I'm marking this bug as verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.