Browser crashes when machine is low on memory M1RC2 [@ imgContainer::FillWithColor]

RESOLVED FIXED in mozilla1.0.1

Status

()

--
critical
RESOLVED FIXED
17 years ago
10 years ago

People

(Reporter: jvr, Assigned: pavlov)

Tracking

({crash, topcrash})

Trunk
mozilla1.0.1
x86
Windows NT
crash, topcrash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Fixed on Trunk][adt 1 RTM] [Needs a=],custrtm-, crash signature)

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

17 years ago
This happend to me few times. Each time I had a system warning message telling
that the system was low on memory. Immediately after, browser crashes, even if
it is just open, but not busy. Software version is Mozilla M0.9.9.

Comment 1

17 years ago
Do you have talkback ID?
Severity: normal → critical
Keywords: crash, stackwanted
(Reporter)

Comment 2

17 years ago
if this can help, here are Talkback Incident IDs related to the reported bug :
TB4261389K, TB4253418E, TB4215708G
Hope it helps.

Comment 3

17 years ago
Stephen, should I ask you for TB4261389K, TB4253418E, TB4215708G?
Keywords: stackwanted
imgContainer::FillWithColor
[d:\builds\seamonkey\mozilla\modules\libpr0n\src\imgContainer.cpp, line 659]
imgContainer::DoComposite
[d:\builds\seamonkey\mozilla\modules\libpr0n\src\imgContainer.cpp, line 532]
imgContainer::Notify
[d:\builds\seamonkey\mozilla\modules\libpr0n\src\imgContainer.cpp, line 458]
nsTimerImpl::Process [d:\builds\seamonkey\mozilla\xpcom\threads\nsTimerImpl.cpp,
line 342]
handleMyEvent [d:\builds\seamonkey\mozilla\xpcom\threads\nsTimerImpl.cpp, line 381]
PL_HandleEvent [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 591]
PL_ProcessPendingEvents [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c,
line 524]
_md_EventReceiverProc [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line
1072] 

Comment 5

17 years ago
Jeremie: Are you able to reproduce this bug with Mozilla Release Candidate 1? 
Any newer talkback?
http://ftp.mozilla.org/pub/mozilla/releases/mozilla1.0rc1/
Assignee: asa → Matti
QA Contact: doron → imajes-qa
Summary: Browser crashes when machine is low on memory → Browser crashes when machine is low on memory [@ imgContainer::FillWithColor]
why not reassign it to the correct component ?

-> Imagelib (new based on the stack)
Assignee: Matti → pavlov
Status: UNCONFIRMED → NEW
Component: Browser-General → ImageLib
Ever confirmed: true
QA Contact: imajes-qa → tpreston
(Assignee)

Updated

17 years ago
Target Milestone: --- → Future
(Reporter)

Comment 7

17 years ago
I've installed Moz1.0rc1 (with talkback). I'll let you know if new crashes occur.
(Reporter)

Comment 8

17 years ago
OK, I think I've got one. Have a look at talkback ID TB5633958K.

Comment 9

17 years ago
Created attachment 81547 [details] [diff] [review]
Cleanup of imgContainer::FillWithColor

What a good opportunity to clean up FillWithColor()

Changes in FillWithColor with this patch:

- New memory allocation reduced to one row of image (bpr).  FillWithColor used
to allocate enough memory to hold the whole image, even though it only used one
row of that memory.

- Validation of memory allocation.  If failed, function exits.

- Check if R, G, & B are the same.  If they are, do a memset and skip memory
allocation alltogether.

- Got rid of some duplicate variables.
(Assignee)

Comment 10

17 years ago
tor can you sr=?
(Assignee)

Comment 11

17 years ago
Comment on attachment 81547 [details] [diff] [review]
Cleanup of imgContainer::FillWithColor

r=pavlov.

style nitpicks for libpr0n:
+	 }
+	 else	    
+	 {	  

should be:
+	 } else {
Attachment #81547 - Flags: review+

Comment 12

17 years ago
Comment on attachment 81547 [details] [diff] [review]
Cleanup of imgContainer::FillWithColor

sr=tor

minor nit: rename "foo" to "tmpRow" or something else that indicates its
purpose.
Attachment #81547 - Flags: superreview+

Comment 13

17 years ago
Created attachment 81634 [details] [diff] [review]
Cleanup of imgContainer::FillWithColor

changes as per reviews, plus I removed the trailing spaces.
Attachment #81547 - Attachment is obsolete: true
(Assignee)

Comment 14

17 years ago
Comment on attachment 81634 [details] [diff] [review]
Cleanup of imgContainer::FillWithColor

carrying over r= and sr=
Attachment #81634 - Flags: superreview+
Attachment #81634 - Flags: review+
(Assignee)

Updated

17 years ago
Target Milestone: Future → mozilla1.0.1
(Assignee)

Comment 15

17 years ago
checked in fix for paper@animecity.nu to the trunk.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 16

17 years ago
Created attachment 84641 [details]
Crash comments and count

Pavlov, these crashes are still happening in the release candidates. This fix
has benn on the Trunk for two weeks and has stopped the crshes there. We need
to get this fix on the branch.

Updated

17 years ago
Keywords: nsbeta1, topcrash
Summary: Browser crashes when machine is low on memory [@ imgContainer::FillWithColor] → Browser crashes when machine is low on memory M1RC2 [@ imgContainer::FillWithColor]
Whiteboard: [Fixed on Trunk]

Comment 17

17 years ago
Terri, can you verify this on the trunk.  Thx.

Comment 18

17 years ago
I have tried to crash this using win XP trunk build 2002052208, I followed
several of the crash comments and this seems to be fixed

Comment 19

17 years ago
Seems like it has been verified on trunk. approving on adt behalf --paul really:)
Keywords: nsbeta1 → adt1.0.0, nsbeta1+
Whiteboard: [Fixed on Trunk] → [Fixed on Trunk][adt 1]

Comment 20

17 years ago
Bug 143333 contains a patch for a regression this bug fix caused.  It also has
been checked into the trunk and confirmed fixed.  You'll probably want it on the
branch as well.

Comment 21

17 years ago
adt1.0.0+ (on ADT's behalf) for approval to checkin to the 1.0 branch, pending
Drivers' approval and the checkin of the fix for Bug 143333.  After, checking
in, please add the fixed1.0 keyword.
Keywords: approval
Whiteboard: [Fixed on Trunk][adt 1] → [Fixed on Trunk][adt 1 RTM] [Needs a=]

Updated

17 years ago
Depends on: 143333
(Assignee)

Comment 22

17 years ago
i have both fixes in my branch tree ready to check in as soon as I get drivers
approval for them

Comment 23

17 years ago
adding the adt1.0.0+ that Jaime mentioned in a previous comment.
Keywords: adt1.0.0 → adt1.0.0+

Updated

16 years ago
Whiteboard: [Fixed on Trunk][adt 1 RTM] [Needs a=] → [Fixed on Trunk][adt 1 RTM] [Needs a=],custrtm-

Comment 24

16 years ago
changing to adt1.0.1+ for checkin to the 1.0 branch.  Please get drivers
approval before checking in.
Keywords: adt1.0.0+ → adt1.0.1+

Comment 25

16 years ago
adding mozilla1.0.1 nomination.
Keywords: mozilla1.0.1

Updated

16 years ago
Attachment #81634 - Flags: approval+

Comment 26

16 years ago
please checkin to the 1.0.1 branch. once there, remove the "mozilla1.0.1+"
keyword and add the "fixed1.0.1" keyword.
Keywords: mozilla1.0.1 → mozilla1.0.1+

Comment 27

16 years ago
has this been checked into branch?

Comment 28

16 years ago
Fixed on branch.
Keywords: mozilla1.0.1+ → fixed1.0.1

Comment 29

16 years ago
Need Bug 143333 checked into branch.  Otherwise Linux people won't be happy.

Comment 30

16 years ago
I will wait to verify for branch until 143333 is fixed (I just removed branch
keyword 'cause the branch is not fixed for that bug)
Crash Signature: [@ imgContainer::FillWithColor]
You need to log in before you can comment on or make changes to this bug.