Closed Bug 1324006 Opened 3 years ago Closed 3 years ago

Event dialog: until date "forever" changes to today date when reopening the dialog

Categories

(Calendar :: Dialogs, defect)

Lightning 5.3
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: bv1578, Assigned: bv1578)

References

(Blocks 1 open bug)

Details

(Keywords: regression)

Attachments

(1 file)

Steps to reproduce:

- create a new event and select any repeating rule (e.g. weekly);
- don't change the default until date "forever", save and close the dialog;
- reopen the event just created.

--> the until date is now set to the today date instead of "forever".

When closing without changing nothing, the save prompt appears.


Regression range:
  build 2016 08 25 works
  build 2016 08 26 fails

https://treeherder.mozilla.org/#/jobs?repo=comm-central&revision=b05a1a42ab8248314f9c2c93ca039f0a1e4cba34

Probably caused by bug 1294534
Thanks for reporting.  I'll take a look when I get a chance.
Attached patch patch-v1Splinter Review
This patch should fix.
Actually only the changes in file lightning-item-iframe.js fixes, but I think it's also needed in react-code.js
Assignee: nobody → bv1578
Status: NEW → ASSIGNED
Attachment #8819616 - Flags: review?(paul)
Comment on attachment 8819616 [details] [diff] [review]
patch-v1

Review of attachment 8819616 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good. Thanks!
Attachment #8819616 - Flags: review?(paul) → review+
Comment on attachment 8819616 [details] [diff] [review]
patch-v1

This is also needed in aurora and beta
Attachment #8819616 - Flags: approval-calendar-beta?(philipp)
Attachment #8819616 - Flags: approval-calendar-aurora?(philipp)
Attachment #8819616 - Flags: approval-calendar-beta?(philipp)
Attachment #8819616 - Flags: approval-calendar-beta+
Attachment #8819616 - Flags: approval-calendar-aurora?(philipp)
Attachment #8819616 - Flags: approval-calendar-aurora+
Correct link for comm-central:
https://hg.mozilla.org/comm-central/rev/97a86c21e6c3

Pushed to comm-aurora
https://hg.mozilla.org/releases/comm-aurora/rev/8cef44d23bc3
Target Milestone: 5.5 → 5.4
Pushed to comm-beta:
https://hg.mozilla.org/releases/comm-beta/rev/e1cda4717bd8
Target Milestone: 5.4 → 5.3
You need to log in before you can comment on or make changes to this bug.