Closed Bug 1324118 Opened 6 years ago Closed 6 years ago

RTL support for devtool framework connection screen

Categories

(DevTools :: Framework, defect, P3)

53 Branch
defect

Tracking

(firefox53 fixed)

RESOLVED FIXED
Firefox 53
Tracking Status
firefox53 --- fixed

People

(Reporter: tomer, Assigned: tomer)

References

()

Details

(Keywords: rtl)

Attachments

(4 files)

Steps to reproduce:

a. Launch an RTL Firefox build
b. Hamburger menu → Developer → Connect… (may appear different due to the browser locale. In Hebrew it is "התחברות…", the item above "View Source Ctrl-U")
c. A new browser tab will open with the chrome://devtools/content/framework/connect/connect.xhtml# page. 

Current result:
Page is localized but doesn't feature direction hints. We need to add dir=&locale.dir; to the page html or body elements.
Comment on attachment 8819446 [details]
[Bug 1324118] RTL support for devtool framework connection screen

https://reviewboard.mozilla.org/r/99214/#review99518

::: devtools/client/framework/connect/connect.css:40
(Diff revision 1)
>    text-align: right;
>    margin-right: 10px;

These properties needs to be replaced with start/end equivalents.

::: devtools/client/framework/connect/connect.css:48
(Diff revision 1)
> +input {
> +  unicode-bidi: plaintext;

This addition will make sure that input fields will be aligned well according to the context. On a second thought, I think I'll hardcode it to LTR, because numerical addresses such as 127.0.0.1 and ::1 doesn't contains a strong bidirectional characters, so the direction will be undetermined.
Attached image patch v1
Attached image patch v2
Comment on attachment 8819446 [details]
[Bug 1324118] RTL support for devtool framework connection screen

https://reviewboard.mozilla.org/r/99214/#review99550

Sounds good to me, thanks for the fix!
Attachment #8819446 - Flags: review?(jryans) → review+
Keywords: checkin-needed
Pushed by ihsiao@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4b72137e0459
[Bug 1324118] RTL support for devtool framework connection screen r=jryans
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/4b72137e0459
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 53
Seems to be working fine in latest Nightly.
Depends on: 1334958
I have reproduced the bug in Nightly 53.0a1 (2016-12-16) with the instruction from comment 0 and Linux 64 Bit

Bug is fixed now on Latest Beta 53.0b7 (Build ID:20170327151342)
User Agent:Mozilla/5.0 (X11; Linux x86_64; rv:53.0) Gecko/20100101 Firefox/53.0

 [bugday-20170329]
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.