uncached background image not rendered

RESOLVED DUPLICATE of bug 129908

Status

()

RESOLVED DUPLICATE of bug 129908
17 years ago
17 years ago

People

(Reporter: tor, Assigned: kmcclusk)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
Steps to reproduce:

  * quit mozilla
  * delete disk cache
  * start mozilla
  * go to www.nasa.gov

Result:

  * page loads with white background
  * scrolling the page causes the dirty areas to show the background image

Expected:

  * page loads with nasa grey strip on the left
(Assignee)

Comment 1

17 years ago
WFM using 2002031803 build on WinXP.
(Assignee)

Comment 2

17 years ago
WFM using cvs build from today on Linux
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

17 years ago
Still broken in an 8:30am pacific 3/21 cvs pull on linux.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Assignee)

Comment 4

17 years ago
I tried going to pref's and dumping the cached images as well as removing the
cache file directly as described in this bug. In both cases the background
always displays when I load the page.

tor: If you reverse my change for preventing the incremental load of the
background images does the problem go away for you?

cvs update -j3.8 -j3.7 mozilla/layout/base/src/nsImageLoader.cpp

(Reporter)

Comment 5

17 years ago
Backing out the nsImageLoader change does fix the problem.

The background image starts loading with the backout after the
rest of the page has finished and the throbber has stopped, fwiw.
(Assignee)

Comment 6

17 years ago
I think what is probably happening is that the background image is not
completing its load so the OnStopFrame method is not being called to invalidate
the window so when you move a window over the top of the browser window you are
seeing the background image as the result of bug 129908 which displays the
partially loaded background image when painting. The throbber stops spinning and
document done is reported before background images have completed their load so
you can not use them to determine if the background image has completely loaded.
(Assignee)

Comment 7

17 years ago
Since I fixed bug 129908 scrolling will not display the background image while
it is loading. When the image has been completely loaded it should display.
Works fine for me using a 2/25/2002 build on WinXP. Resolving as a dup of 129908.



*** This bug has been marked as a duplicate of 129908 ***
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.