Closed Bug 1324924 Opened 3 years ago Closed 3 years ago

Implement ImageBitmap for TexImage

Categories

(Core :: Canvas: WebGL, defect, P1)

Unspecified
All
defect

Tracking

()

RESOLVED FIXED
mozilla53
Tracking Status
firefox50 --- wontfix
firefox51 --- fixed
firefox52 --- fixed
firefox53 --- fixed

People

(Reporter: jgilbert, Assigned: jgilbert)

References

Details

(Keywords: dev-doc-complete, Whiteboard: gfx-noted)

Attachments

(4 files, 1 obsolete file)

No description provided.
Attachment #8820439 - Attachment is obsolete: true
Attachment #8820439 - Flags: review?(dmu)
Comment on attachment 8820438 [details]
Bug 1324924 - Add ImageBitmap entrypoints. -

https://reviewboard.mozilla.org/r/99924/#review100416

r=me, but this should presumably be folded with the next changeset, so we don't have non-compiling changesets in the tree.
Attachment #8820438 - Flags: review?(bzbarsky) → review+
Comment on attachment 8820437 [details]
Bug 1324924 - ImageBitmap::ToCloneData should be const and return a UniquePtr. -

https://reviewboard.mozilla.org/r/99922/#review100450
Attachment #8820437 - Flags: review?(mtseng) → review+
Comment on attachment 8820440 [details]
Bug 1324924 - Add implementation for ImageBitmaps. -

https://reviewboard.mozilla.org/r/99928/#review100466
Attachment #8820440 - Flags: review?(dmu) → review+
Pushed by jgilbert@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/6b721c404cec
Support ImageBitmap for Tex*Image*. (flattened) - r=bz,daoshengmu,mtseng
Approval Request Comment
[Feature/Bug causing the regression]: webgl2
[User impact if declined]:
[Is this code covered by automated tests?]:
[Has the fix been verified in Nightly?]:
[Needs manual test from QE? If yes, steps to reproduce]: 
[List of other uplifts needed for the feature/fix]:
[Is the change risky?]:
[Why is the change risky/not risky?]:
[String changes made/needed]:
Attachment #8820600 - Flags: review+
Attachment #8820600 - Flags: approval-mozilla-beta?
Attachment #8820600 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/6b721c404cec
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
Comment on attachment 8820600 [details]
placeholder for all patches

Fix WebGL2 related issue. Beta51+ & Aurora52+. Should be in 51 beta 10.
Attachment #8820600 - Flags: approval-mozilla-beta?
Attachment #8820600 - Flags: approval-mozilla-beta+
Attachment #8820600 - Flags: approval-mozilla-aurora?
Attachment #8820600 - Flags: approval-mozilla-aurora+
Sorry had to back this out for WebGLRenderingContext.webidl dependency, and bustage caused by bug 1324543. This will be landed with bug 1317625 and bug 1324543.
see comment 16 from iris
Flags: needinfo?(jgilbert)
Duplicate of this bug: 1187812
You need to log in before you can comment on or make changes to this bug.