If you minimize the browser window and you have the Permission window open, this will not minimize

RESOLVED WORKSFORME

Status

()

Firefox
Device Permissions
RESOLVED WORKSFORME
8 months ago
8 months ago

People

(Reporter: Ovidiu, Unassigned)

Tracking

(Depends on: 1 bug)

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox53 affected)

Details

(Whiteboard: [fxprivacy])

Attachments

(1 attachment)

(Reporter)

Description

8 months ago
[Affected versions]:

FF Nightly 53.0a1


[Affected platforms]:


Tested on Mac OS X 10.10


[Steps to reproduce]

 1. Go to https://mozilla.github.io/webrtc-landing/gum_test.html
 2. Click "Screen"
 3. After the Permission Window appears, minimize the browser window


[Expected result]:

The Permission window is minimized at the same time with the browser window.


[Actual result]:

The Permission Window doesn't disappear.
(Reporter)

Comment 1

8 months ago
Created attachment 8820721 [details]
Recording #12.mp4
(Reporter)

Updated

8 months ago
Blocks: 1004061
Panos, do you know if this is already covered by one of the platform blockers we have? I couldn't reproduce locally on my machine (I'm on OS X 10.11, not sure if that explains the difference).
Flags: needinfo?(past)
Whiteboard: [fxprivacy][triage]
Yes, this was known for a long time. Recent macOS versions seem to have this fixed, but it's still an issue on Linux and Windows last I checked. Bug 1320341 should fix this.
Depends on: 1320341
Flags: needinfo?(past)
Whiteboard: [fxprivacy][triage] → [fxprivacy]
Wrong dependency, the other bug was mac-only.
Depends on: 1320361
No longer depends on: 1320341
The video linked in the original bug report (comment 1) is certainly the Mac-only bug 1320341, which is now fixed.

I don't see this bug on Windows.

This still occurs on Linux, but that is covered by bug 1320361.
Thank you, I don't have macOS 10.10 here so I tested on Linux, hence the dependency change. If Ovidiu can verify the fix we could even resolve this bug and deal with the Linux case in the dependent bug.
(Reporter)

Comment 7

8 months ago
Hi, 

Sorry for the delay, I tested this bug on Mac Os X 10.10 with Firefox 53.0a1 (2016-12-26) (64-bit) and I can't reproduce it any more. 
Thanks Panos, you are right the bug was fixed. I will mark this as Resolved WFM.
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.