Closed Bug 1325375 Opened 3 years ago Closed 3 years ago

Activity stream - Context menu is not displayed when tapping the 3 dots menu icon

Categories

(Firefox for Android :: General, defect, P1)

53 Branch
ARM
Android
defect

Tracking

()

VERIFIED FIXED
Firefox 54
Iteration:
1.15
Tracking Status
firefox53 --- affected
firefox54 --- verified

People

(Reporter: carmenf, Assigned: ahunt)

References

(Blocks 1 open bug)

Details

(Whiteboard: [MobileAS])

Attachments

(1 file)

Environment: 
Device: Asus Transformer Pad (Android 4.2.1);
Build: latest Nightly 53.0a1 (2016-12-21);

Prerequisites: Activity stream enabled.

Steps to reproduce:
1. Launch Firefox;
2. Tap on the 3 dots menu icon of a website from Activity stream panel (either Top sites or Highlights area);

Expected result:
Context menu is properly displayed.

Actual result:
Nothing happens, the context menu is not displayed.

Notes:
This issue is reproducible only on Asus Transformer Pad; on Nexus 9 (Android 7.0) and Asus ZenPad (6.0.1) the context menu is displayed when tapping the 3 dots menu.
Priority: -- → P2
This one is looking like good fun: once I get the PopupWindow to show (we don't set a height/width by default, so somehow the PopupWindow decides not to show on the Asus devices), I run into:
https://code.google.com/p/android/issues/detail?id=190498
Assignee: nobody → ahunt
Iteration: --- → 1.14
Priority: P2 → P1
I'm not getting very far with fixing the weird borders, so I'll focus on just making the menu visible here - I've filed bug 1333545 to then fix the appearance.
Blocks: 1333545
Comment on attachment 8830004 [details]
Bug 1325375 - Followup: extend popupmenu size workaround to all 4/5 devices

https://reviewboard.mozilla.org/r/106948/#review108208

Argh.

Isn't our main menu a PopupWindow too?
Attachment #8830004 - Flags: review?(s.kaspari) → review+
Pushed by ahunt@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8332dc26820c
Make PopupContextMenu visible on Android 4 Asus tablets r=sebastian
https://hg.mozilla.org/mozilla-central/rev/8332dc26820c
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 54
Duplicate of this bug: 1336133
The issue was fixed on Asus Transformers Pad (Android 4.2.1). 
Still reproducing on tablets, I was able to reproduce it on the following devices: 
- Lenovo Yoga Tablet 2 (Android 4.4.2);
- Xiaomi Mi Pad 2 (Android 5.1, x86);
- Huawei MediaPad M2 (Android 5.1.1).
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Iteration: 1.14 → 1.15
Pushed by ahunt@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/dbf09755c433
Followup: extend popupmenu size workaround to all 4/5 devices r=sebastian
https://hg.mozilla.org/mozilla-central/rev/dbf09755c433
Status: REOPENED → RESOLVED
Closed: 3 years ago3 years ago
Resolution: --- → FIXED
Tested with the latest Nightly build 54.0a1 (2017-02-16) using the following devices:
- Huawei MediaPad M2 (Android 5.1.1);
- Xiaomi Mi Pad 2 (Android 5.1, x86);
- Lenovo Yoga Tablet 2 (Android 4.4.2);
- Asus Transformer Pad (Android 4.2.1).

Context menu is now displayed after tapping the 3 dots menu icon (for both Top sites and Highlights).

I'm marking this as Verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.