Closed Bug 1325578 Opened 3 years ago Closed 7 months ago

DPR value is changed when zooming in or out when in RDM

Categories

(DevTools :: Responsive Design Mode, defect, P2)

defect

Tracking

(firefox50 unaffected, firefox51 unaffected, firefox52 wontfix, firefox53 affected)

RESOLVED WORKSFORME
Tracking Status
firefox50 --- unaffected
firefox51 --- unaffected
firefox52 --- wontfix
firefox53 --- affected

People

(Reporter: bogdan_maris, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: regression, Whiteboard: [rdm-v2])

Attachments

(1 file)

[Affected versions]:
- Latest Nightly 53.0a1
- Latest Developer Edition 52.0a2

[Affected platforms]:
- Windows 8.1 32-bit
- Windows 10 64-bit
- Ubuntu 16.04 64-bit
- Mac OS X 10.12.1

[Steps to reproduce]:
1. Start Firefox
2. Visit a random webpage
3. Enter RDM (CTRL+Shift+M / CMD+Alt+M)
4. Zoom in/out

[Expected result]:
- DPR value remains the same.

[Actual result]:
- DPR value changes.

[Regression range]:
- This is not a recent regression, it's visible in old Nightly from 2016-11-08 as well, where DRP was introduced.

[Additional notes]:
- Screencast attached showing the issue
Has Regression Range: --- → no
Has STR: --- → yes
QA Whiteboard: [qe-rdm]
Has Regression Range: no → irrelevant
Depends on: 1022006
Huh, that's quite strange!  I don't think it's actually related to 1022006, we're not even zooming the content at all...

At the moment, zoom actions target the RDM UI only (we do want to change that, bug 1278758), and the DPR should reflect the content, which hasn't changed.

Also, the DPR value seems to change only once, but then never again as you keep zooming...?!  Very strange!
Blocks: 758011
No longer blocks: 1237360
No longer depends on: 1022006
Priority: -- → P2
Whiteboard: [rdm-v2]
Probably related: Bug 1342549 - RDM-V2 - DPR box shows very long number of decimal digits at certain zoom levels
Mass wontfix for bugs affecting firefox 52.
Product: Firefox → DevTools

With the recent zoom fixes done to RDM, I do not believe this happens anymore. At least I was not able to reproduce on macOS with Firefox 69.
So let me close this for now. Please feel free to re-open if you think it still occurs.

Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.