Closed Bug 1325738 Opened 3 years ago Closed Last month

Add support for custom Prompts in Fennec

Categories

(Testing :: Marionette, defect, P3)

Version 3
ARM
Android
defect

Tracking

(firefox51 unaffected, firefox52 disabled, firefox53 disabled)

RESOLVED WONTFIX
Tracking Status
firefox51 --- unaffected
firefox52 --- disabled
firefox53 --- disabled

People

(Reporter: intermittent-bug-filer, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: test-disabled, Whiteboard: [test disabled])

Attachments

(1 file)

This failure happened in enforce_gecko_prefs() while restarting Firefox. 

Excerpt from gecko.log:

> 1482529361622	Marionette	TRACE	conn16 -> [0,12,"deleteSession",null]
> 1482529361626	Marionette	TRACE	conn16 <- [1,12,null,{}]
> [..]
> 1482529549682	Marionette	DEBUG	Marionette enabled via build flag and pref
> 1482529550202	Marionette	INFO	Listening on port 2828

It means there were 188056ms (~3min) between the requested shutdown and the listener socket being created.  There is no crash report, so not sure what's going on here.
We do no longer restart Firefox to enforce a preference. As such the failure has been changed, and seems to be permanently visible for tests against Fennec.
Summary: Intermittent test_modal_dialogs.py TestGlobalModals.test_alert_accept | IOError: Process killed because the connection to Marionette server is lost. Check gecko.log for errors (Reason: Timed out waiting for connection on localhost:2828!) → Intermittent test_modal_dialogs.py TestGlobalModals.test_alert_accept | IOError: Process has been unexpectedly closed (Exit code: 0) (Reason: Connection timed out after 60.0s)
The failures seem to only be present for modal dialogs but not tab modal dialogs, and happen when clicking it:

[task 2017-01-09T10:31:11.708353Z] 10:31:11     INFO -      self.marionette.find_element(By.ID, 'modal-alert').click()
[task 2017-01-09T10:31:11.708447Z] 10:31:11     INFO -    File "/home/worker/workspace/build/venv/local/lib/python2.7/site-packages/marionette_driver/marionette.py", line 82, in click
[task 2017-01-09T10:31:11.708521Z] 10:31:11     INFO -      self.marionette._send_message("clickElement", {"id": self.id})

The issue for Fennec here is that the test stops once the modal dialog opens. There is no reply coming back for the click command and as such we hang until the socket timeout.

For now I will just disable the modal dialog tests and leave the tab modals running. I may have to restructure the tests for that.
Summary: Intermittent test_modal_dialogs.py TestGlobalModals.test_alert_accept | IOError: Process has been unexpectedly closed (Exit code: 0) (Reason: Connection timed out after 60.0s) → Modal dialogs block execution of code in Marionette server for Fennec
As it looks like it doesn't matter which preference value is set, the dialogs always end up as modal dialogs. Maybe Fennec doesn't support tab modal dialogs? For now I'm going to skip the full test module for Fennec.
Blocks: 1297394
Comment on attachment 8825731 [details]
Bug 1325738 - Skip test_modal_dialogs.py for Fennec

https://reviewboard.mozilla.org/r/103816/#review104550
Attachment #8825731 - Flags: review?(mjzffr) → review+
Pushed by hskupin@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/eb30cfd7f4e7
Skip test_modal_dialogs.py for Fennec r=maja_zf
https://hg.mozilla.org/mozilla-central/rev/eb30cfd7f4e7
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
Reopening bug given that the patch which landed simply disabled the tests until a proper solution is in place.

Can you please uplift to aurora? Thanks.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Whiteboard: [test disabled]
Whiteboard: [test disabled] → [test disabled][checkin-needed-aurora]
https://hg.mozilla.org/releases/mozilla-aurora/rev/e06ca5fc05b8
Whiteboard: [test disabled][checkin-needed-aurora] → [test disabled]
Target Milestone: mozilla53 → ---
Closing as intermittent has not been seen in last 45 days
Status: REOPENED → RESOLVED
Closed: 3 years ago3 years ago
Resolution: --- → WORKSFORME
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
This is not an intermittent, looks like a missing feature
Status: REOPENED → RESOLVED
Closed: 3 years ago2 years ago
Resolution: --- → FIXED
Nothing is fixed here. The test is still disabled.
Status: RESOLVED → REOPENED
Keywords: test-disabled
OS: Unspecified → Android
Hardware: Unspecified → ARM
Resolution: FIXED → ---
Priority: -- → P3

The problem is that for Fennec we have a custom prompt implementation, which can be found here:
https://searchfox.org/mozilla-central/source/mobile/android/modules/Prompt.jsm

Because of that we aren't able yet to detect those prompts because they are different than modal dialogs or tab modals in Firefox.

Blocks: 1528358
Status: REOPENED → NEW
Summary: Modal dialogs block execution of code in Marionette server for Fennec → Add support for custom Prompts in Fennec
Blocks: 1578783

Fennec is no longer supported, and for GeckoView the code should be completely different. As such we don't want to fix this bug.

Status: NEW → RESOLVED
Closed: 2 years agoLast month
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.