User-typed strings in the "Search for ... with" not being remembered/forgotten after clearing the location bar across different tabs

NEW
Unassigned

Status

()

P5
normal
2 years ago
3 months ago

People

(Reporter: itiel_yn8, Unassigned)

Tracking

unspecified
Points:
---

Firefox Tracking Flags

(firefox61 affected, firefox62 affected, firefox63 affected)

Details

(Whiteboard: [DUPEME][fxsearch])

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
STR:
1. Open a new tab
2. Type anything in the location bar, don't press enter. Observe your typed text in "Search for ... with" in the search suggestions
3. Clear any words you've entered in step 2
4. Click the small triangle button in the location bar
5. The previously typed text (which the user cleared) reappears in the "Search for ... with"

The same can be seen also if you open a new tab before step 4.

Note that in Private Browsing about the same issue appears, only if you open a new tab before step 4.
(Reporter)

Updated

2 years ago
See Also: → bug 1325822
(Reporter)

Updated

2 years ago
Summary: User-typed string in the "Search for ... with" not being forgotten after clearing the location bar → User-typed strings in the "Search for ... with" not being forgotten after clearing the location bar and opening a New Tab
(Reporter)

Updated

2 years ago
Summary: User-typed strings in the "Search for ... with" not being forgotten after clearing the location bar and opening a New Tab → User-typed strings in the "Search for ... with" not being remembered/forgotten after clearing the location bar across different New Tabs
(Reporter)

Comment 1

2 years ago
The issue was shifted a little in latest Nightly, new STR:
1. Open a New Tab
2. Type anything in the location bar, don't press enter. Observe your typed text in "Search for ... with" in the search suggestions
3. Open a New Tab
4. Click the small triangle button in the location bar
5. The previously typed text (which the user cleared) still appears in the "Search for ... with" in this New Tab

The same bug could be said about the following STR:
1. Open a New Tab
2. Type "abc" in the location bar, don't press enter. Observe your typed text in "Search for ... with" in the search suggestions
3. Open a New Tab
4. Type "def" in the location bar, don't press enter. Observe your typed text in "Search for ... with" in the search suggestions
5. Move back to the previously opened tab (in step 1) and click the small triangle button in the location bar
6. The "def" still appears in the "Search for ... with", even though it should have been "abc"
(Reporter)

Updated

2 years ago
Summary: User-typed strings in the "Search for ... with" not being remembered/forgotten after clearing the location bar across different New Tabs → User-typed strings in the "Search for ... with" not being remembered/forgotten after clearing the location bar across different tabs
I think we fixed this some months ago.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

a year ago
(In reply to Marco Bonardo [::mak] from comment #2)
> I think we fixed this some months ago.

Nope, both STRs in comment 1 are still valid in latest Nightly.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Reporter)

Updated

a year ago
Status: REOPENED → NEW
It doesn't reproduce for me, with neither of those STR. Maybe try in Safe Mode? https://support.mozilla.org/kb/troubleshoot-firefox-issues-using-safe-mode
(Reporter)

Comment 5

a year ago
(In reply to Marco Bonardo [::mak] from comment #4)
> It doesn't reproduce for me, with neither of those STR. Maybe try in Safe
> Mode?
> https://support.mozilla.org/kb/troubleshoot-firefox-issues-using-safe-mode

It's reproducible for me also on a new and fresh profile.
See attached demo for the second STR on comment 1.
(Reporter)

Comment 6

a year ago
Created attachment 8915992 [details]
Demo on a new profile
ah sigh, I thought you were referring to the action row (the first result) not the footer area! My fault, sorry.

I think this may be a duplicate of an existing bug, since I've already seen something like that.
Priority: -- → P2
Whiteboard: [DUPEME]
Whiteboard: [DUPEME] → [DUPEME][fxsearch]
(Reporter)

Updated

a year ago
status-firefox57: --- → affected
status-firefox58: --- → affected
See Also: → bug 1360227
(Reporter)

Comment 8

5 months ago
This seems to be irrevelant anymore as the search term is not showing up there at all now.
Status: NEW → RESOLVED
Last Resolved: a year ago5 months ago
Resolution: --- → INVALID
(Reporter)

Updated

3 months ago
Status: RESOLVED → REOPENED
status-firefox57: affected → ---
status-firefox58: affected → ---
status-firefox61: --- → affected
status-firefox62: --- → affected
status-firefox63: --- → affected
Resolution: INVALID → ---
(Reporter)

Updated

3 months ago
Status: REOPENED → NEW

Updated

3 months ago
Priority: P2 → P5
You need to log in before you can comment on or make changes to this bug.