Last entered term in the location bar is seen in the one-offs bar

NEW
Unassigned

Status

()

defect
P5
normal
2 years ago
7 months ago

People

(Reporter: simona.marcu, Unassigned)

Tracking

(Blocks 1 bug)

unspecified
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox63 affected, firefox64 affected, firefox65 affected)

Details

(Whiteboard: [fxsearch])

Attachments

(1 attachment)

Posted video Screencast.mp4
Mozilla/5.0 (Windows NT 10.0; rv:55.0) Gecko/20100101 Firefox/55.0\
Build ID: 20170427030231

[Affected versions]:
- Nightly 55.0a1

[Affected platforms]:
- All

[Steps to reproduce]:
1. Launch Firefox
2. In the Awesome bar type Mozilla and press enter
3. Open a new tab
4. Press the Up key

[Expected result]:
- Step 4: The autocomplete drop-down is opened showing the last accessed websites. The one-off bar should be empty since there is nothing written in the location bar (Search with:)

[Actual result]:
- Step 4: "Search for Mozilla with:" is displayed in the one-offs bar, even if the location bar is empty.
Please see the screencast for more details.


[Additional notes]:
- This issue is reproducible also in Firefox 51 when the preference browser.urlbar.oneOffSearches is set to true.
This is a polish item, but not a critical blocker. I think Drew fixed one or two similar bugs recently, so I'm a bit surprised this was not caught by existing tests.
No longer blocks: 1337003
Priority: -- → P2
Whiteboard: [fxsearch]

Updated

2 years ago
See Also: → 1325819

Updated

2 years ago
Version: 55 Branch → unspecified

Comment 2

Last year
Same as bug 1325819, this doesn't seem to be relevant any longer.
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → INVALID

Comment 3

Last year
Not sure what has changed, but this became relevant again.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---

Updated

Last year
Priority: P2 → P5

Updated

7 months ago
Has STR: --- → yes

Updated

7 months ago
See Also: → 1509317

Updated

7 months ago
See Also: → 1482563
You need to log in before you can comment on or make changes to this bug.