Autophone - throbber stop regression 2016-12-23

RESOLVED FIXED

Status

defect
RESOLVED FIXED
3 years ago
8 months ago

People

(Reporter: bc, Unassigned)

Tracking

(Blocks 1 bug, {regression})

unspecified
Dependency tree / graph

Firefox Tracking Flags

(fennec53+, firefox52 unaffected, firefox53 fixed)

Details

(Whiteboard: [fixed-by-1328747])

That should have read: Bug 1319850
Blocks: 1319850
and seen on perfherder:
== Change summary for alert #4608 (as of December 23 2016 17:09 UTC) ==

Regressions:

  6%  remote-twitter summary android-4-2-armv7-api15 opt     2580.55 -> 2737.59
  4%  remote-blank summary android-6-0-armv8-api15 opt       839.64 -> 874.67
  3%  remote-twitter summary android-6-0-armv8-api15 opt     967.22 -> 993.66
  2%  remote-blank summary android-4-4-armv7-api15 opt       1276.51 -> 1304.9

For up to date results, see: https://treeherder.mozilla.org/perf.html#/alerts?id=4608
There was a synchronous creation even added in Bug 1319850. That's the only thing I can think of that might be causing this. I've created a patch that tries to eliminate or at least decrease it's impact. I'll run on try to see if it addresses the issue.
Not sure how to test if this patch addresses the issue. The try build posted in Comment 4 has finished.
Randall, you should post the patch and get this in
tracking-fennec: ? → 53+
Flags: needinfo?(rbarker)
(In reply to James Willcox (:snorp) (jwillcox@mozilla.com) from comment #7)
> Randall, you should post the patch and get this in

Since I couldn't figure out if this patch helped with regression I created Bug 1328747. I just pushed it to inbound. If things improve I guess we can close this. Otherwise I'm not sure what to look at to fix this issue.
Flags: needinfo?(rbarker)
bug 1328747 did improve things. -> fixed
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-by-1328747]
Product: Firefox for Android → GeckoView
You need to log in before you can comment on or make changes to this bug.