VP9 decoding broken by webrtc.org 49 update - YCbCr pointers are off

VERIFIED FIXED in Firefox 53

Status

()

P1
normal
Rank:
12
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: ekr, Assigned: jesup)

Tracking

unspecified
mozilla53
Points:
---

Firefox Tracking Flags

(firefox53 verified)

Details

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Created attachment 8822510 [details]
Screen Shot 2016-12-29 at 12.42.41 PM.png

Seen on AppRTC
(Reporter)

Comment 1

2 years ago
This is the video from Canary -> Firefox

I also see the same thing on Chrome Release -> Firefox.
(Assignee)

Comment 2

2 years ago
Caused by the Webrtc 49 update.
pc_test.html has been updated to include a force-vp9 option which shows the problem.  The plane pointers for YCbCr on VP9 decode appear to be wrong.
Rank: 12
Depends on: 1250356
Priority: -- → P1
Summary: Severe visual artifacts on a call between Canary and Nightly → VP9 decoding broken by webrtc.org 49 update - YCbCr pointers are off
(Assignee)

Comment 3

2 years ago
Created attachment 8822575 [details] [diff] [review]
Restore patches for bug 1237023 and bug 1315283 - lost in 49 update
Attachment #8822575 - Flags: review?(pkerr)
(Assignee)

Updated

2 years ago
Assignee: nobody → rjesup
Status: NEW → ASSIGNED

Updated

2 years ago
Attachment #8822575 - Flags: review?(pkerr) → review+

Comment 4

2 years ago
Pushed by rjesup@wgate.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/e548798fe7ce
Restore patches for bug 1237023 and bug 1315283 - lost in 49 update r=pkerr
Blocks: 1250356
No longer depends on: 1250356

Comment 5

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/e548798fe7ce
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox53: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
We'll cover this on Beta 53 through our WebRTC compatibility testing rounds. Setting ni? to myself as a reminder.
Flags: needinfo?(andrei.vaida)
I have reproduced the issue mentioned in comment 0 by following the steps mentioned in comment 1, using an affected Firefox 53.0a1 (Build Id:20161229030206) build. 

I have verified that the issue is not reproducible using Firefox 53.0b6 (Build Id:20170323090023) performing the following calls:
Windows 10 64bit (Firefox Beta) - Mac Os X 10.11.6 (Chrome Release).
Mac Os X 10.11.6 (Firefox Beta) – Windows 10 64bit (Chrome Release).
Ubuntu 16.04 64 bit (Firefox Beta). - Windows 10 64 bit (Chrome Release).
Windows 10 64bit (Firefox Beta) – Ubuntu 16.04 64bit (Chrome Release).
Mac Os X 10.11.6 (Firefox Beta) -Ubuntu 16.04 64 bit (Chrome Release).
Ubuntu 16.04 64bit (Firefox Beta) – Mac Os X 10.11.6 (Chrome Release).
Status: RESOLVED → VERIFIED
status-firefox53: fixed → verified
Flags: needinfo?(andrei.vaida)
You need to log in before you can comment on or make changes to this bug.