Closed Bug 1326377 Opened 3 years ago Closed Last year

Media view 'Save As ...' for embedded(?) picture fails

Categories

(SeaMonkey :: Page Info, defect)

SeaMonkey 2.5 Branch
Unspecified
Windows 7
defect
Not set

Tracking

(seamonkey2.49esr affected, seamonkey2.53 affected, seamonkey2.57esr fixed, seamonkey2.60 fixed)

RESOLVED FIXED
seamonkey2.60
Tracking Status
seamonkey2.49esr --- affected
seamonkey2.53 --- affected
seamonkey2.57esr --- fixed
seamonkey2.60 --- fixed

People

(Reporter: RainerBielefeldNG, Assigned: frg)

References

Details

Attachments

(2 files)

I found this one during my research for "Bug 1326262 - Some Entries on Media Tab in Page Info Use Gray Text"

Steps how to reproduce with Server-Installation of  unofficial (by FRG) en-US SeaMonkey 2.50a1 (NT 6.1; Win64; x64; rv:53.0) Gecko/20100101 Firefox/53.0 Build 20161219235428  (Default Classic Theme) on German WIN7 64bit:

1. Visit <http://slashdot.org/>
2. Menu 'View → Page Info → Media (tab)'
3. Scroll media list, select a greyed "data:..." list entry
4. [Save as ...] → select folder and save
   » Something seems to be saved,                              but
   bug: download Manager will not offer "open containing folder" 
        because nothing has been saved (open folder manually  and check)
If I change the suggested file name ("index") before saving, using some image-like extension (f.e. ".jpg"), then the Download Manager offers "Open" and "Open Containing Folder" options for me – using:

Mozilla/5.0 (Windows NT 10.0; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0 SeaMonkey/2.49a2
Build identifier: 20161224023459

It looks more like Download Manager problem, as the same (saving the data: URI image using plain "index" name) works fine in Firefox – I can "Open Containing Folder" with it just fine.
(In reply to Rainer Bielefeld from comment #0)
>    bug: download Manager will not offer "open containing folder" 
>         because nothing has been saved (open folder manually  and check)

This actually works for me – I see an "index" file of proper length saved on the file system, but Download Manager still doesn't offer to "Open Containing Folder".
(In reply to Stanimir Stamenkov from comment #2)
I also did some successful savings of greyed items from Media list now. I will do separate tests concerning reasons for railed attempts.
I did some more tests: download ('Save as ...') from Page Info - Media reliably fails for me if I save with suggested name "index".

This seems to be a very old regression worked for me (on WIN7 64bit) with SeaMonkey 2.0.1, fails with 2.5 and all later versions.
a) FF 53.0a1 (2016-12-15) (32-bit) does the job correctly
b) tests are a little difficult because the affected contents changes very often
   on that page, but I am pretty sure that the problem does not depend on 
   contents of those "data:...." pictures, I saw (at least at first appearance)
   same picture contents failing with 2.5 and successful "Save as" with 2.0.1
See Also: → 1326262
Version: SeaMonkey 2.50 Branch → SeaMonkey 2.5 Branch
Confirmed.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [easyconfirm]
Flags: needinfo?(frgrahl)
Duplicate of this bug: 1392276
Assignee: nobody → frgrahl
Status: NEW → ASSIGNED
The calls got accidently modified in Bug 796994. Because of this you run into Bug 1207168 in 2.57 and above.

The patch corrects the calls and fixes a download failed. I took the regular expression from Firefox. It was the same in SeaMonkey but did behave different because of the surrounding code. This resulted in a download failure if you selected data url images on slashdot.

Need to do a separate patch for 2.49.5.
Flags: needinfo?(frgrahl)
Attachment #8989827 - Flags: review?(iann_bugzilla)
Attachment #8989827 - Flags: approval-comm-esr60?
Comment on attachment 8989827 [details] [diff] [review]
1326377-Pageinfo.patch

LGTM r/a=me
Attachment #8989827 - Flags: review?(iann_bugzilla)
Attachment #8989827 - Flags: review+
Attachment #8989827 - Flags: approval-comm-esr60?
Attachment #8989827 - Flags: approval-comm-esr60+
Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/269d5aedfd3f
Media view 'Save As ...' for embedded(?) picture fails. r=IanN
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.60
When the dust settles I will look at a 2.49.x backport.
You need to log in before you can comment on or make changes to this bug.