Closed Bug 1326446 Opened 3 years ago Closed 3 years ago

Firefox should offer ability to add "Google Chrome like" customized search engines

Categories

(Firefox :: Search, defect)

50 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1336604

People

(Reporter: gwmfms6, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/55.0.2883.87 Safari/537.36

Steps to reproduce:

At some point in the past, Mozilla decided to remove the functionality of "searchplugins" folder. Which on Debian based Linux distros used to be generally located at /home/$USER/.mozilla/firefox/qwerty.default/searchplugins.


Actual results:

Users can no longer make use of customized search engines. For example, I used to have a customized version of DuckDuckGo created with URL parameters as my default search engine. Since the removal of the "searchplugins" folder functionality from Firefox, my customized engines no longer work.

As a result of Mozilla's decision to remove this essential feature, I gave up on Firefox and went to Google Chrome where I can easily add URL-parameter created engines and assign them as my default engine or give them a keyword and use them as an alternative engine.

Why doesn't Firefox have a simple setup like Google Chrome does for adding customized engines? Further, why was the method that was in place removed without a replacement ready to go?


Expected results:

Users should be able to add customized search engines, like can be done in Google Chrome.

I leave this feedback for you in the hopes that you guys can turn Firefox around and bring back users. Functionality like this though is essential and never should have been removed.
Component: Untriaged → Search
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1336604
You need to log in before you can comment on or make changes to this bug.