Return value "false" or "0" isn't displayed when stepping out of a function

RESOLVED DUPLICATE of bug 1476615

Status

defect
P3
normal
RESOLVED DUPLICATE of bug 1476615
3 years ago
6 months ago

People

(Reporter: arni2033, Assigned: tromey)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

>>>   My Info:   Win7_64, Nightly 49, 32bit, ID 20160526082509
STR_1:
1. Open attached "testcase 1"
2. Open debugger, set breakpoint in script at line with "for"
3. Click on the page content
4. Click "Step In" in debugger several times to switch to line "return false;"
5. Click "Step In" in debugger
 (bonus - there's already bug, but you can continue)
6. Click "Step In" in debugger several times to switch to line "return 0;"
5. Click "Step In" in debugger, then click it again

AR:  No visible action
ER:  Return value should be displayed in "variables" tab

Note:  This is reproducible starting from 2013-06-13, so bug 773590 wasn't completely fixed
No longer blocks: 1277113
Component: Untriaged → Developer Tools: Canvas Debugger
Component: Developer Tools: Canvas Debugger → Developer Tools: Debugger
Duplicate of this bug: 1280503
The other was marked as P3.
Priority: -- → P3
Fixing this in debugger.html.
Assignee: nobody → ttromey
Should be in the next bundle.
Depends on: 1338567
This can't be said to truly be fixed because the fix will affect the console and the debugger,
but not the variables view, which the console still uses.
Depends on: 1308566
Darn it, wrong bug.
No longer depends on: 1338567
I may eventually get these edits right.
Depends on: 1338567
No longer depends on: 1308566
Fixed by the latest bundle.
Status: NEW → RESOLVED
Closed: 3 years ago
Flags: qe-verify+
Resolution: --- → FIXED
Successfully reproduce this bug on Nightly 49.0a1 (2016-05-26) (Build ID: 20160526083057) by the following Comment 0's instruction!

This Bug is now Verified as Fixed on Latest Firefox Nightly 54.0a1 (2017-03-05) (64-bit)

Build ID: 20170305110158
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:54.0) Gecko/20100101 Firefox/54.0
OS: Linux 4.8.0-39-generic; Ubuntu 16.04.2 (64 Bit)
QA Whiteboard: [testday-20170303]
Product: Firefox → DevTools
Since this issue had a qe+, we figured that it could be tested on latest Nightly/Release.
However, running testcase from comment 0 is not possible in 66/64. I wonder if there is something we're missing or there is a regression in debugger. Tom, could you advise? (see https://imgur.com/a/fUfI2qM )
Flags: needinfo?(ttromey)
You could try pretty-printing the source perhaps.
Otherwise I am not sure, forwarding to :jlast.
Flags: needinfo?(ttromey) → needinfo?(jlaster)
Whiteboard: [qa-triaged]

this is a duplicate of 1476615

Flags: needinfo?(jlaster)

As per comment 13, moving the resolution to this issue as duplicated after bug 1476615.

Flags: qe-verify+
Resolution: FIXED → DUPLICATE
Whiteboard: [qa-triaged]
Duplicate of bug: 1476615
You need to log in before you can comment on or make changes to this bug.